Right setup for a Digium TE122 as PRI on a german E1 line?

Hello,
we have a Digium TE122 and tryed to set it up today

Unfortunatly we ran into problems.
We are not sure if our telco needs to check if their port is up, if
our cabeling is correct or if something else is wrong.

What we want to do:

  • Connect TE122 to a german E1 as a PRI

Setup:
TE122 ----->
RJ45 ------>
Outlet from telco technician (changing some pin-mappings inside of the cable) ----->
–> E1 Modem

  • Jumper on the card is set, so it should run in E1 mode.
  • Card doesn’t sync with the telco-side. “zttool” gives a YELLOW alert
    all the time and says the timing source is local.
  • When attaching a loopback cable to the card it instantly turns GREEN
    and the loopback tests work fine.
  • We used a standard RJ-45 Patch cable to attach the TE122 to the
    outlet the telco technician provided for us.
  • When we checked that outlet, it seems that it crosses some cables inside.

We are unsure about the right cable for our setup.
Someone in #asterisk on freenode suggested a RJ48c cable instead of our setup.

What would be the right cabeling for using the card with a german E1?
It would be no problem to skip the telco-outlet to directly connect
our TE122 to the E1 Modem with the right cable.

Our /etc/zaptel.conf at the moment:

span = 1,1,0,ccs,hdb3,crc4,yellow
bchan=1-15
dchan=16
bchan=17-31
language=de

Thanks and sorry for the bad english…
Daniel

sounds to like the screw up is on the telco side. Maybe they wired the port as a crossover port?

A standard ethernet patch cable is all you need; its the same pin assignment for E1\T1 as ethernet.

To make sure can you rig something up that you can put the loopback connector on the end of the cable that will connect into the E1 port from the telco?

If you are getting a yellow then you are getting layer 1 . Have you asked your telco to bring the circuit into service and do the datafill.

A e1 will not normally be brought into service till you ask.

Ian

Thanks for your answers. The problem was on the telco side. They resetted our port and it started working afterwards.

Now i can make outgoing calls without problems.

Incoming calls aren’t going thrugh. when trying to make an inbound call i just get the “number not available” message from my telco. what might be the cause for that?

i created a “s” extension in the context for the E1 card but calls seem to never reach asterisk.

i am not sure if it might be the hardware-setup ? I am using a standard RJ45 patch cable at the moment. Digium suggested to use a RJ48c which is basicly the same but has got only the 4 needed wires, not the other ones. I am not sure if that would make any difference?

Another thing:
The card doesn’t get the telco side as timing source, but i set that option in the span in zaptel.conf. any ideas?

tnx a lot.

sorry forum hang, deleted this doublepost…

Hi

You cannot normaly use the s extension for DID calls or the like, It is for calls that have no destination information or Macros.

You will be getting your DDI calls in with either all the number or the last 6 or 4. you need to ask your telco what they are sending you.

A simple hack is to send the calls to a extension such as _x. this will match any number of any length. so for example

exten => _x.,1,Goto(default,${EXTEN),1)

will call the number that comes from the telco that is in the default context

Ian