[RESOLVED] Trixbox inbound calls not received

I’m using:
Latest updated Trixbox
Teliax SIP
Server and phones are nat’ed behind same firewall with all relevant ports forwarded (have tried in DMZ w/ same results)

I can dial out fine. When I dial in to my DID, I only hear “bye” on the phone and then get hung up on. Nothing shows up in the CLI asterisk -r display, but here is a log of sip debug during the inbound call attempt. I’m assuming my extensions.conf is messed up, perhaps?

Here’s my sip.conf
Here’s my extensions_additional.conf w/ default data deleted for brevity.
Here’s my extensions.conf which I think is default but I’m not sure. I swear I set up the inbound routes in FreePBX like I think you’re supposed to.

What I want:
I’m not greedy, at this point I would just be happy if my extension (111) rang when the DID is dialed. Ideally I want to have it try one extension first, but forward to another extension when it’s busy. Then the icing on the cake would be time constraints, but let’s not get ahead of ourselves. I promise I’ve done days of reading, and I’ve figured a lot out on my own, but I just can’t get further on this without a little assistance.

Thanks in advance for your help.

I’m not smart enough to tell from your log.
Look in your debug log /var/log/asterisk/full*.*
find the file with the right date/time and look for when your call came through. this may shed light on the error.

Make sure your codecs are set up so that all peers support eachother. This happened to me and I was getting a similar error. BTW you aren’t getting a Bad Request in the asterisk -r interface right? Also make sure you have verbose set to 10 “set verbose 10”


There’s my “full” log with the time of the call as requested. Thanks for telling me how to set verbosity higher, now I see:

Executing Playback(“SIP/bizname-0a259858”, “vm-goodbye”) in new stack

How do I make sure all my codecs are set up so that all peers support eachother?

Thanks for your help so far, we’re narrowing in on it!

Here’s an updated post of my log file. It repeatedly schedules the destruction of calls, when calls are not being made, is this normal?


Here you see my inbound attempt, and the playing of the vm-goodbye file. Unsure why it’s not routing to my extension.

I think you might get more help in the Trixbox and/or FreePBX forums.

Thanks, took your advice. This seems to be a more popular forum though, hoping somebody can still help out. :laughing:

SOLVED! By my new hero, baconbuttie. He found that I had “context=default” (as I was directed by Teliax) and extensions.conf had default route to goodbye. So we changed it to context=from-trunk and all is right.

Thank you baconbuttie! :smiley:

Thank you others who lent a hand as well!!