[RESOLVED] Out Bound Dialling through Alcatel


#1

Dear All,

I am running

Centos 4.2
Asterisk 1.2.6
Zaptel 1.2.5
Libpri 1.2.2
Sangoma A101 (Wanpipe Beta4-2.3.4)

The Asterisk server is configured with 3 sip extensions (5001, 5002 and 5003) which have been tested and can all contact each other.

There is an E1 trunk between the Asterisk Server and the Alcatel 4400 which allows me to ring any of the company extensions running off the Alcatel from any of the SIP extensions. This has also been verified.

The Alcatel expects all calls made to it which are intended for PSTN routing to have a pre-fix of #18. However, when I try to dial an outside PSTN number from one of the SIP phones I get the message below from the Asterisk Console and a busy signal from the SIP phone.

Connected to Asterisk 1.2.6 currently running on voipfax (pid = 2741)
Verbosity is at least 3
– Executing Dial(“SIP/5002-0696”, “ZAP/g1/#1802890531500||f”) in new stack
– Requested transfer capability: 0x00 - SPEECH
– Called g1/#1802890531500
– Zap/1-1 is proceeding passing it to SIP/5002-0696
– Channel 0/1, span 1 got hangup request
– Hungup ‘Zap/1-1’
== Everyone is busy/congested at this time (1:0/0/1)
– Executing Congestion(“SIP/5002-0696”, “”) in new stack
== Spawn extension (internal, 902890531500, 102) exited non-zero on ‘SIP/5002-0696’

Here is a copy of extensions.conf that I am using.

[globals]
OUTBOUNDTRUNK=ZAP/g1
TRUNKMSD=1
PRE_DIAL_local=#18

[incoming]
exten => s,1,Answer()
exten => s,n,Playback(test-system)
exten => s,n,Hangup

[internal]
include => outbound-extensions
include => outbound-local
exten => _[5]xxx,1,NoOp("call for "${EXTEN})
exten => _[5]xxx,2,Dial(SIP/${EXTEN},60,tr)
exten => _[5]xxx,3,Congestion

[outbound-extensions]
exten => _9[1-4]XXX,1,Dial(${OUTBOUNDTRUNK}/${EXTEN:1})
exten => _9[1-4]XXX,2,Congestion()
exten => _9[1-4]XXX,102,Congestion()

[outbound-local]
exten => _9XXXXXXXXXXX,1,Dial(${OUTBOUNDTRUNK}/${PRE_DIAL_local}${EXTEN:${TRUNKMSD}},f)
exten => _9XXXXXXXXXXX,2,Congestion()
exten => _9XXXXXXXXXXX,102,Congestion()

I have went through the forums, readmes and the Asterisk manual but no joy on how to overcome this. I have the feeling I’m snowblind on this one and missing something obvious. Any and all suggestions would be tried and appreciated.

Cheers

Stephen


#2

Hello,

Have you tried to trace the call on Alcatel side? Sa you will see what is going on.

Regards,
Mircea.


#3

Hi Mircea,

From the command line interface on the Alcatel I have been running

trkstat -r

I can see the channel go from F (Free) to B (Busy) so I know that it’s seeing the call being passed to it from Asterisk.

I don’t have the Alcatel knowledge to trace it further than this but have now raised a support request with Alcatel to see if they can offer up more tracing options.

While it looks like something which needs adjusting on the Alcatel side I would appreciate any thoughts on anything I can do from the * side to help the process along.

Cheers

Stephen


#4

DOH!

Following an e-mail from Alcatel I managed to track down the issue.

A trunk had been created on the Alcatel specifically to test the Asterisk Server. However, the entity code (along the lines of a context I suppose)for the trunk did not have permissions to access the PSTN.

Nice one Mircea, knew I was suffering from snow-blindness. Always worth getting a fresh pair of eyes on the subject.


#5

Hy,

So you solved the problem?

A tracer on Alcatel you can run with the following command:

t3 cr <cristal_nb> cpl <cpl_nb>

Cristal nb and copler nb are those where you have the PRA2 board.

This will run a tracer on ISDN, in which you will see the messages exchanged bettwen Alcatel and Asterisk. You can stop the tracer pressing DEL or CTRL+C (depending on Alcatel release).

Best regards.