[RESOLVED] Odd issue when ringing 2 phones at once

Hello, and thanks for taking the time to look at my post.
Maybe you can help me with a strange issue I’m having with my Asterisk server.
Any pointers or suggestions at all will be greatly appreciated!

0. Links to my .conf files
First of all, here are links to the relevant configuration files. Only my username(s), secret(s), caller ID and provider name have been changed. The IP addresses have been masked. Everything else is exactly like in the .conf files I am using.

extensions.conf http://warpster.org/extensions_conf.txt
sip.conf http://warpster.org/sip_conf.txt
iax.conf http://warpster.org/iax_conf.txt

1. Environment and devices involved:
I am using the latest release of Asterisk from source (version

I have a Sipura 3000 box with my PSTN line connected to its “line” port, and a plain old analog phone connected to its “phone” port.

I also have a Linksys WIP300 phone which registers with the Asterisk server. For now, I am only using this device while within range of my private wireless network. Therefore, there are no NAT or port forwarding concerns.

2. What I’m trying to do:
I would like both phones to ring at the same time when receiving an inbound call on my PSTN line.

3. Description of the issue:
Both the phone connected to the Sipura and the Linksys wireless IP phone can make outbound calls just fine, using SIP to talk to Asterisk which then uses IAX2 to connect to my provider, which terminates the call. However, when I receive an INBOUND call, only the phone connected to the Sipura rings, even though I have (near as I can tell) put the correct syntax in extensions.conf to ring both phones at the same time.

What is most strange about this issue is that both phones will ring at the same time, doing exactly what extensions.conf tells them to, but only when I dial from the Asterisk console, like this:

However, when a real call comes in through the PSTN line, the wireless phone won’t ring, while the phone connected to the Sipura will still ring properly.

Does anyone have an idea of what I am doing wrong? I have been messing around with this for the last 3 days and I am feeling pretty stumped right now.
Thanks in advance for any advice!


try this

exten => s,1,Dial(SIP/sipura_phone&SIP/wireless_phone,30,r)
exten => s,2,Hangup

Hi Rusty and thanks for your quick reply.

I tried your suggestion, but the result was the exact same behavior I was having with the original extension.conf (without omitting ‘homephoneline’).

Any more ideas?


turn on verbose does the cli show in errors?

I turned a huge level of verbosity on, but strangely when a call comes in through the PSTN line, no messages whatsoever appear in the console (even though any phones connected directly to the PSTN and the phone connected to the Sipura ring as described in my original post). By contrast, when I dial the homephoneline extension from the console, Asterisk tells me that both phones are ringing, like so:

Hope this helps,

Edit: I did however get the following message a little while after I tried what you suggested. I don’t know if it’s related to the PSTN line ringing, because it showed up a couple of minutes later, and in the meanwhile I had also tried again to dial from console. Also, it doesn’t really seem relevant to what we’re talking about. Be that as it may, the message was:

…where 192.168.x.x is the address of the Linksys wireless phone.

in the spa3000, do you have ring through for pstn to line one disabled?
And in the dialplan on the spa3000, do you have it sending all calls to the asterisk box?

My default dialplan for incoming calls on the pstn line in the spa3000 looks like
(S0<:192.168.1.x>) <= ip masked
And then I set “PSTN Caller Default DP:” to the enty above.

That way all incoming calls are handed off the the asterisk server and it will ring my analog and sip phones…

I used this guide to set it up on a Trixbox…

voip-info.org/wiki/view/Aste … OFXSDevice

Thanks engjohn for your suggestion. I tried following the guide, but it doesn’t seem to work. However, what you said led me to understand better what is needed… and now I think I realize that there is a problem with the Sipura passing calls to Asterisk.

When the PSTN line rings, the phone connected to the Sipura rings, but the Asterisk console shows no activity whatsoever. I guess this means that the call isn’t actually being passed to Asterisk. I thought that configuring the PSTN-to-VOIP gateway as per your suggestion would do the trick, but it doesn’t seem to change anything.

Does anyone have any pointers of things to look at to troubleshoot this issue? Any further insight would be greatly appreciated. Thanks.

Edit: Also engjohn, to answer your question, I tried with ring through both enabled and disabled. If I disable it, the phone connected to the Sipura won’t even ring anymore. If I leave it enabled, only the Sipura phone will ring (same situation as my original issue).

I had issues setting mine up the first time as well.

I learned a few things.

  1. run the latest firmware
  2. after updating firmware, call into the box using an analog phone (the **** codes) and reset it back to defaults.
  3. carefully go through the setup offered online.

I think on my 3 or 4th attempt I made it work.

If you pm me your email address, I will send you a web config dump from my sipura…
Then you can see exactally how mine is setup.

Thanks a lot engjohn, but I think I solved this. I ended up upgrading the firmware and resetting to factory defaults, and just like you say I found that to be very helpful… the “right way” I guess.

Now I just need to learn more about Asterisk to make it do all the cool things I have in mind… but that’s another story :smile:

Thanks again to everyone who tried to help, and I’m setting this topic to “resolved”.