Softphones are unable to call each other


#1

Hi everyone,

I was working on a test Asterisk server for my company a few months back, but it got put on hold, and now we’re rebuilding it to begin testing again, however we’re running into a problem for which I’m sure there is a very simple solution (though I cannot find it).

The server is already setup with a basic dialplan in place. What I’m trying to do for the time being is to get 2 softphones to be able to call each other. Both of the phones can dial into the Asterisk server and can communicate with the IVR.

However, when I try and Dial from one softphone to the other, Asterisk will not ring the receiving phone.

So for example, in my dial plan, as a test, I’m using

exten => xxxx,1,Dial(SIP/username,10)

So both users have their phones already initialized in the sip.conf file, and they are both registering with Asterisk fine. However, when I do the call, I get the following -

– Executing Dial(“SIP/myname”, “SIP/username|10”) in new stack
– Called username

Then it stops (until it times out). It never rings the destination phone. So it never gets to the part

– SIP/username is ringing

I have checked port and firewall settings, and they all appear to be set properly. I have not tried a reinstall of Asterisk yet, as I’m hoping that this is a simple fix.

Below are the 2 accounts that I have created in the sip.conf file, just with their usernames masked.

Any help would be greatly appreciated.


[myname]
type=friend
context=default
regexten=5310
host=dynamic
mailbox=5310@default

[username]
type=friend
context=default
regexten=6333
host=dynamic
mailbox=6333@default


#2

Are these phones on the same LAN? if not try using canreinvite=no


#3

Yes, they are on the same LAN.


#4

I have checked port and firewall settings

This it what baffles me, what Firewall when they are on the same net ?

Is the asterisk server also on the same lan segment?

Eg.
Phone 1: 192.168.0.1
Phone 2: 192.168.0.2
Asterisk: 192.168.0.250

Then there is no way a firewall should get involved.
Somehow that sounds odd to me…

Is the CLI showing that both phones registered conrrect with the pbx (asterisk) ?

It DOES sound like a UDP/RTP port ptoblem, but shouldnt considering all is on the same (internal) lan…


#5

A software firewall - I disabled it (I’m not even sure why it was started in the first place, we don’t need it).

The 3 current systems are all on the same LAN segment (the Asterisk server, and the 2 machines hosting the SIP phones).

Both phones are registering fine with Asterisk.

With all of the fluff (comments) taken out of the sip.conf file, this is what I’m left with.


[general]
context=default
bindport=5060
bindaddr=0.0.0.0

[myname]
type=friend
context=default
regexten=5310
host=dynamic
mailbox=5310@default

[username]
type=friend
context=default
regexten=6333
host=dynamic
mailbox=6333@default


And I’m trying to use the basic stdexten macro that comes with the sample configurations of Asterisk.


#6

Ok, im sorry to bug you with more questions, but this problem is weired so it has a weired reason so we need to ask weired questions :laughing:

Ok, first of all, do you have a dog?
That was a joke…

Ok, serious:
What softphones are these ?
What is the rtp.conf reading like (etc/asterisk) ?

What is the command
sip show peers

reading back ? (enter on the CLI)

Also, please set a password in the softphones and add the appropiate line to sipconfig
secret=mypassword

The reason is, that SOME softphones act strange without authentification.
They might so SOME calls, some not… (config dependend)

PS:
If they are on WIndows XP, make sure the IP Protocol firewall (build in) is also disabled !!

PPS.:
If the machines are on a wireless network, make sure you have no “dos attack” protection, cause wireless networks are causing a LOT of fragmented packets, making almost every firewall believe of dos-attacks and causing the originator (here the IP softphone machine) to be blocked.

I know…you said you disabled the firewall, but also note, that “disabled” doesnt means REALLY disabled on eg. Sygate or outpost. Some mechanisms are STILL active.

Only safe way is to REALLY deinstall them.


#7

Hey, first I must say thanks for helping me try and resolve the problem.

I am using the x-lite softphone (the most recent download from their site).

The rtp.conf file is as follows

[general]
rtpstart=10000
rtpend=20000

My ‘sip show peers’ command is as follows (however I have just commented out the names for security reasons)

sip show peers
Name/username Host Dyn Nat ACL Port Status
theirname/theirname 172.25.20.13 D 5060 Unmonitored
myname/myname 172.25.20.45 D 5060 Unmonitored
2 sip peers [2 online , 0 offline]

All firewalls on all systems have been disabled/removed while trying to correct the issue. The machines are not on wireless. I will give the password suggestion a try momentarily and get back to you.

Once again, thanks for your help.

P.S. After adding passwords for the softphones, there was no change.


#8

The x-lite softphone is kind of a bitch, not the easiest to configure and to start with :imp:

Just to check their config, or better: To exclude them as the reason, can u quickly download this one and setup/try ?

snom.com/snom360softphone.html

PS.:
No problem helping, thats what this forum is for!


#9

I’ve never seemed to have problems with x-lite before, I used it previously when I had setup the system. I did however just notice that there is a new release of Asterisk that came out today. I’m going to go install that and see what happens.


#10

huh ?

This is no asterisk problem, there are “some” more out there using softphones :wink:

Cmon, get the snom softphone QUICK and try, there is no easier way to figure out if the pbx or softphoneconfig is the problem.

Reinstalling a new asterisk is MUCH more of work.

Just my 0.02…


#11

snom did not make a difference.


#12

Ok, so obv. the asterisk side.

That you always talk about “username” and “myname”, but in your
SIP SHOW PEERS posting there is “theirname” is correct, you said you changed due to securityreasons, correct ?

The sip show peers should read exactly like the sip register from the conf (context) is named, so “myname” and “username”.

Just to make sure.

Sorry mentioning this, but this problem is odd and normally this is the most easy thing and should work, so it must be a very easy mistake. So easy, that it wont come to mind…

Again:

Sip.conf

[11]
context=default
secret=apassword
type=friend
regexten=11
callerid=Jane <11>
host=dynamic
nat=no
canreinvite=yes
mailbox=11@default

[12]
context=default
secret=apassword
type=friend
regexten=12
callerid=John <12>
host=dynamic
nat=no
canreinvite=yes
mailbox=12@default

Softphones:
Username
John (or Jane)
Password: apassword
registrar (proxy) 172…

Extensions.conf

exten=>11,1,dial(Sip/11,45)
exten=>11,2,hangup

exten=>12,1,dial(Sip/12,45)
exten=>12,2,hangup

Both softphones are using NOT G.729 and confogured to the same codec, prefered:

disallow=all
allow=ulaw
allow=alaw
allow=gsm

And this isnt working ?

The asterisk CLI makes me wonder, there should be the usual
SIP/11 is ringing

or

No route to host

message. But NOTHING ?
Makes you wonder…

Is there maybe a firewall on the asterisk box itself ?


#13

Sorry for the confusion with ‘theirname’ and ‘username’, that was a typo that I made in trying to clarify the problem. They are infact the same person.

After fiddling around with many softphones, the problem was infact the x-lite softphone (I don’t believe that I had configured snom correctly). However, the managers of the company would really prefer to use x-lite, as it is what we were using before. Do you have any ideas as to what could be causing the issue? It is setup the same way that is described through the Asterisk Guru’s website, and therefore I cannot think of anything else that could be wrong with it.


#14

Sso it was the softphone config.
I wondered already… - your asterisk was looking correct.

X-Lite…well, i hate it:
I had so many problems with it too.
Maybe i am an idiot, to dumb to get it working above the standard “voipbuster” use :stuck_out_tongue: - but i stopped bothering with it and used
SIPP phone from then on, which isnt freeware tho !

Or Softsnom…

Im not sure what X-Lite’s problem is:
I set up the proxy/registrar, the username and the password and still the bit…wasnt working. Not sure, like said: I didnt bother and used SIPP and Snom from then on, because i use softphones only for some testings and VPN employes working from home.


#15

Alright, I’ll give SIPP a try. We managed to get it working with Express Talk, but there’s just something about it that I don’t enjoy. Thanks so much for your help.


#16

No problem buddy, anytime.

Just make sure you check something important:
With SIPP your users should NOT! use the “call forward” function of the softphone:
Its causing a local fallback in asterisk resulting in a loop !!

Might be my config tho… :smiling_imp: