[resolved] No Analog ports has been detected on your system

I’ve successfully downloaded, built and installed asterisk 1.4, zaptel 1.4 and libpri 1.4. When I use the gui I get

“No Analog ports has been detected on your system”

I have a tdm400b card installed with 2 modules which works fine if I reboot into my trixbox install.

I have tried

modprobe zaptel
modprobe wctdm

which both run with no errors and I can see them loaded with lsmod. Also when I look in the asterisk log it tries to run I can see

– Executing [executecommand@asterisk_guitools:1] System(“Local/executecommand@asterisk_guitools-590d,2”, “/sbin/zapscan.bin”) in new stack
/bin/sh: /sbin/zapscan.bin: No such file or directory
[Jan 26 16:33:00] WARNING[12047]: app_system.c:105 system_exec_helper: Unable to execute ‘/sbin/zapscan.bin’

My /etc/zaptel.conf is

channel 2, WCTDM, inactive.

channel 3, WCTDM, inactive.


Global data

loadzone = us
defaultzone = us

I’m not sure about what to do as in trixbox I have /etc/init.d/zaptel which I can start. this does not appear to be there.

Please can someone offer my some advice I’ve been trying to get this working for 2 days now and cannot find anything to help in the forums.

Thanks in advance

Try running this command.

ztcfg -vv

It should print your hardware configuration as zaptel see’s it.

If that looks ok, then take at look at zapata.conf. That is where you configure Asterisk to use the zaptel device.

In Asterisk 1.2, you can run ‘zap show channels’ from the console to show the zaptel channels configured by Asterisk. I have not used 1.4, so this command may not be exactly the same.


For some reason when you installed the gui the zapscan script didn’t get built or placed into /sbin/. Update your gui sources and reinstall it. I assume this was a bug.

ok here’s the output

ztcfg -vv
Zaptel Version: 1.4.0
Echo Canceller: MG2

Channel map:

Channel 01: FXO Kewlstart (Default) (Slaves: 01)
Channel 04: FXS Kewlstart (Default) (Slaves: 04)

2 channels configured.

and in asterisk;

*CLI> zap show channels
Chan Extension Context Language MOH Interpret
pseudo from-internal en default
1 from-internal en default
4 from-zaptel en default

So why does the asterisk gui setup wizard say “no analog ports has been detected on your system”? It looks to me like they are there.

Read my comment above!

thanks you must be right, unfortunately even after a re-checked out asterisk-gui and recompiled and installed I still have that file missing! I’m using

svn checkout svn.digium.com/svn/asterisk-gui/trunk asterisk-gui

I guess I may have to retry tomorrow and see if someone has corrected this. If you know where I can check out or download a working version please let me know.

for now ive fixed it.

just copied /usr/src/asterisk-gui/tools/scanzap.bin /sbin

Ok so it definitely looks like a bug in the gui as it doesn’t copy it over to /sbin. Is it now detecting your hardware?

yes it detects and works now.

im having this same problem, i have everything installed, i just copied the zapscan.bin to the /sbin/folder (it was not there)
cp /usr/src/asterisk-gui/tools/zapscan.bin /sbin/

i had all the files from svn trunk today for asterisk, libpri, zaptel and asterisk-gui

mine is still not working, my zaptel.conf is ok
]# ztcfg -vv

Zaptel Version: SVN-trunk-r2226
Echo Canceller: MG2

Channel map:

Channel 01: FXO Kewlstart (Default) (Slaves: 01)
Channel 02: FXO Kewlstart (Default) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Slaves: 04)

4 channels configured.

lan5CLI> zap show channels
Chan Extension Context Language MOH Interpret Blocked State
pseudo default default In Service
1 default default In Service
CLI> zap show status
Description Alarms IRQ bpviol CRC4
Wildcard TDM400P REV I Board 1 OK 0 0 0
lan5CLI> zap show channel 1
Channel: 1
File Descriptor: 13
Span: 1I>
Dialing: no
Context: default
Caller ID:
Calling TON: 0
Caller ID name:
Destroy: 0
InAlarm: 0
Signalling Type: FXO Kewlstart
Radio: 0>
Confno: -1
Propagated Conference: -1
Real in conference: 0
DSP: noI>
Relax DTMF: no
Dialing/CallwaitCAS: 0/0
Default law: ulaw
Fax Handled: no
Pulse phone: no
Echo Cancellation: 1 taps unless TDM bridged, currently OFF
Actual Confinfo: Num/0, Mode/0x0000
Actual Confmute: No
Hookstate (FXS only): Onhook

== Parsing ‘/etc/asterisk/extensions.conf’: Found
– Executing [executecommand@asterisk_guitools:1] System(“Local/executecommand@asterisk_guitools-cf4d,2”, “/sbin/zapscan.bin”) in new stack
– Executing [executecommand@asterisk_guitools:2] Hangup(“Local/executecommand@asterisk_guitools-cf4d,2”, “”) in new stack
== Spawn extension (asterisk_guitools, executecommand, 2) exited non-zero on 'Local/executecommand@asterisk_guitools-cf4d,2’
fd == -1 in astman_append, should not happen
fd == -1 in astman_append, should not happen
== Parsing ‘/etc/asterisk/zapscan.conf’: Found

ALSO, i noticed every time i go trough the setub and zapscan.bin runs, it adds fxoks=1,2
to the bottom of the zaptel.conf file even though this file already has this info on it, and after this happens i get this:

ztcfg -vv

Notice: Configuration file is /etc/zaptel.conf
line 235: Channel 1 already configured as ‘FXO Kewlstart’ at line 134
line 235: Channel 2 already configured as ‘FXO Kewlstart’ at line 134
line 236: Channel 3 already configured as ‘FXS Kewlstart’ at line 133
line 236: Channel 4 already configured as ‘FXS Kewlstart’ at line 133

4 error(s) detected


It detects the zap ports if I run asterisk as root.

Must be a permission problem.
To be continued …