[resolved]grandstream BT200 registered but can not dial out


i know this is a very common scenario but im just wondering why it runs in 2-different spot but not in this particular spot?

my setup is this …

The firewall port forward 5060-5080 and 8000-2000 UDP from/to Asterisk box. and there were no firewall enable in Draytek router.
The BT200 and n80i were registered in asterisk and can receive incoming calls. however although i can hear dial tone as i pciked up the handsedt in BT200 my dialed number seems will not go to asterisk server. i set verbose 5 in asterisk to see if there were any trial dial attempts from BT200/n80i but there were not so i can say that the dialed number goes somewhere.
and when n80i regesitered i see this “400 Bad request” error

i have read from here but did not help
asteriskguru.com/tutorials/s … erisk.html

the Draytek LAN has two vonage client phones but i tried to off that two phones and restart the Draytek and restart again but still the same error.

the surprising thing was i tried n80i in different Setup like this

note the same as first there were no firewall i the last two and the there were call in/out problem.

and here is my

and i have play canreinvite to no/yes and no luck

in rtp.conf
startp = 8000
endrtp = 20000

any experience which is very similar to this?

Shooting the obvious: do you really have two identical entries in sip.conf for gs_bt200?

If I understand correctly, the difference between working and non-working configurations is the router near the phone. (And I still fail to see what’s the difference between the two working configurations.) If that, I’d blame Draytek. What is its exact configuration when you say “no firewall” (do you mean the end points are on public IP?), and how is it different from Zyxel’s?

oh forget about that i just miss to copy and paste two times,
let me edit and remove the second one,

the firewall in draytek doesnt block nor allow anything when it comes to port.

zyxel the same thing all default which allow all traffic.

phones were not in public they are still behind router that allow all traffic

Even more curious. If phones are not publicly routable, the router would have to do (asymmetric) NAT, I assume? How is it possible to allow all traffic to all phones on an asymmetric NAT? Or are you doing symmetric? I must be missing something here.

ok i install and tested xlite-3.0 with STUN=public ip of firewall that forwarrd UDP to asterisk server and manuallyassigned port = 5060-5062

everything is ok

here is my sip.conf


a “symmetric NAT is detected” as i use stun.xten.net

Have to say that symmetric NAT is not all that common :wink: So soft phone works but hard phone won’t work? That’s a little confusing. But I suspect that the Draytek is doing something different from Zyxel. Can you enable STUN on the hard phones like you did with Xlite? Or simply replace Draytek with something known to work.

i already use stun.xten.net as my stun and that i read in gstream status that i have a symmetric NAT.

today that is my plan to use another modem and router and i hope the existing 2-unit of vonage phone w/ ATA connected to vonage server will remain working and also this grandstream and n80i which i want to connect to my asterisk server.

i figured it out a week ago…

what i did was, change a new router and now its working, the LAN
has 2-vonage sip phone(or course vonage client) and my grandstream BT200 for asterisk.:smile: