= undefined symbol: __pure_virtual

hello -

I’m trying to run but appears to be some kind of link trouble. After I compile and install the addons package, I get this error below when I load asterisk.


[]Jun 14 09:09:19 WARNING[14354]: loader.c:325 __load_resource: /usr/lib/asterisk/modules/ undefined symbol: __pure_virtual
Jun 14 09:09:19 WARNING[14354]: loader.c:499 load_modules: Loading module failed!

Enviroments tried are:

  1. Debian / Asterisk / GCC 3.3.5 / MySQL 5.0.22
  2. Suse10 / Asterisk / GCC 4.0.2 / MySQL 5.0.20a

Do you have any suggestions as to what I might be doing wrong? Thanks!

I was dinking around in MySQL on the Suse box and somehow got it working… have no clue what I did. For the time being resolution is PFM. I’ll try to do the same on Debian… if I get it to work and know what I did, I’ll update this post. If anyone in the meantime has any idea, please let me know. Thanks!

Me to I have the same error. Same system
Debian, Asterisk-, Addons-1.2.3, mysql-5.0.22

Maybe is it the bug?
Thanks for some suggestions

Hello to all !

I had the same problem on Fedora 4
but I have found a simple solution!

Just install "MYSQL Linux x86 generic RPM (dynamically linked)"
and recompile asterisk addons.

That’s ALL! :smile:

Best regards.