Res-config_ldap.c: No directory URL


#1

I’m a newbie and I’m trying to install Asterisk for the first time. After checking the file /var/log/asterisk/messages I noticed an Error “res-config_ldap.c: No directory URL or host found” after a Notice “res_config_ldap.c: No directory user found, anonynous binding as default”.
I checked on menuselect and it is checked but apparently it is not being included at the make. How can I fix this?

There is also a few Warnings after the error like “chan_dahdi.c: Ignoring any changes to ‘userbase’ (on reload) at line 23”

Thanks


#2

The modules is included but the configuration is incomplete.

The warning can be ingnored, it is simply saying that these items won’t be updated on a reload, but you are not doing a reload and you are not updating them.


#3

david55 thanks for your reply

I’m ignoring the warnings but how do I fix the error? I executed ./configure, then menuselect and checked that it was selected. Then make , make install and make config. In that order. Just following the steps from their Asterisk Essentials video. Did I miss something?


#4

You have to manually configure /etc/asterisk/res_ldap.conf


#5

david55,

I haven’t got to that point in the course so I thought that removing it from menuselect would get rid of the error, but no. Even after removing it from menuselect and executing make and make install and restarting asterisk, the error persists. Now, Asterisk is running. Let me explain this better.
What I’m trying to do is set up a softphone to connect to the asterisk server. The one used in the video is x-lite and I downloaded and installed it and configured it. But it does not connect. That’s why I thought that the error of the ldap module was the problem. Coult it be it?
My server is running on vmware and has IP: 192.168.7.130 . The linux server has a different IP: 192.168.7.53. I’ve tried using both IPs but it does not connect. I pinged from my PC the server and viceversa and got replies on both.

I know that the problem now is completely different but since I got you involved, maybe you can help me.
If not I’ll post another topic.

Thanks


#6

Deleting the module from the modules directory will probably get rid of the error message, but that would not have been fatal.

Domain in the X-Lite set up should be the address of the Asterisk (virtual) machine, never the VM host.

For simplicity, username and authorization user name should match the section name in sip.conf and the password should match the secret, or md5secret in that section.

Register with domain should be ticked and the domain option selected.


#7

Tried that but it does not get enabled.

There is a sonic wall in our network and I created access routes from my IP to the asterisk server and back using SIP. Should I have anything else opened?

Do you have any ideas why would this be happening?


#8

If it manipulates the SIP headers, you may have fun.

You need to have the RTP port ranges open, but that will produce silent calls, rather than a failure to set up.


#9

Thanks davidd55 for your replies. I still have the same problem so I’m going to post again with a different subject and see if i get other replies.

Thanks again.