Remote X-Lite calling into Local Extension

Hi, all.

I have a Trixbox locally that has 3 extensions configured so far. 2 are local to the Trixbox and one that is remote running on a Winbloze machine. I can call a local extension from the remote extension just fine. Everything works. However, when I try to call the remote extension from one of the local extensions, I get the message that the person is not available. I’m guessing it’s a firewall issue. But I’ve allowed UDP ports 5060 and 8000-8005 through to the Windows machine.

What am I missing?

Thanks in advance…

This sounds like a similar problem and I recently read a solution posted here that I’m sure will will be of help in the necessary configurations. Try the following thread and let us know how it went.

Thanks, Techieg.

This is very good information that I can use. However, it doesn’t completely address my problem I don’t think. I still will have the same problem of trying to call my remote extension (at another location) from my local extension (at the same location as my * server).

I’m going to implement the points brought out in the thread you referenced. But that won’t fix my problem entirely, will it?

Thanks again…

It should take care of your problem. I personally set up another remote voip network with that config and it rocks. Just follow every configuration and let’s hear how it goes.

I’ve made the changes you referenced in the thread. However, I still can’t call from local extension to remote extension. Keep getting “the person you are trying to reach is not available…”. Using Logmein, I took the firewall the remote firewall down long enough to try the call then, but it failed again. THat tells me that it’s not the firewall. Must be something in my configuraition of my Trixbox. Any ideas?

Thanks in advance…

Check to see if the extension you are trying to call is registered. On the * CLI you can run ‘sip show peers’ and see if that extension is on the list of registered peers. Make sure it is able to receive calls as a ‘peer’ or ‘friend’, and make sure its in the right context. You just basicly need to check the extension authentication config and make sure all ports you allow through are both TCp and UDP.

OK. Here’s the output of the ‘sip show peers’ command:

Name/username Host Dyn Nat ACL Port Status
501/501 (Unspecified) D N 0 UNKNOWN
101/101 D N 5060 OK (432 ms)
100/100 D 19706 Unmonitored
3 sip peers [2 online , 1 offline]
Verbosity is at least 1
Core debug is at least 1

501 is the extension in question. One question comes up immediately; I see NAT is N on that extension. I’ve made the changes to sip.conf as specified in the thread. However, the thread also suggested making some changes to the ‘authentication settings for each remote extension’. Adding nat=yes and canreinvite=no. Where is that added? It’s in my Trixbox configuration for the extension. But is there a file that I should put that in?

*** Edit *** I got it! I found an error with instead of But also found that in the X-Lite configuration, the box that tells it to register with the host wasn’t checked. I checked that and it works fine now. Thank you for all your help, Techieg.

Its clear that extension 501 is not registered. On the page where you configured extension 501 you should be able to enter this information there. Or click ‘Config Edit’ on the GUI and you will be taken to a page where you can click to open any config file you want to configure. Click to open sip.conf and under that particular extension config you should be able to enter this info. It should then look like this:


Also make sure that your sip.conf general setting has the following:

externip=123.456.789 [size=75]<–Enter appropriate values for your * server[/size]
localnet= [size=75]<–Enter appropriate values for your server[/size]

After editing your configs make sure you click the ‘re-read files’ or ‘re-read configuration’ at the top of the config page so that * can apply the changes.