Remote-Party-ID using ARI

Hello, I am using ARI to make calls using the endpoint
POST /channels
I would like to pass the caller’s number in the Remote-Party-ID.
To do this, I include it in the variables:

Unfortunately, the Remote-Party-ID is not being added.
I have checked the sip.conf file and it is configured with:
sendrpid=yes
trustrpid=yes

Where else can I look for the reason why the number is not being passed in RPID?

number is not a documented option.

(Also chan_sip is unsupported.)

name and number works fine: