Asterisk and Linksys SPA942


I don’t have a question, although earlier I was close to posting. Instead I wanted to share what I figured out today.

Since we installed our Asterisk system a couple months ago, every so often the linksys extensions would playback a message along the lines of “this device is not registered to make calls on the internet” when a number was dialed. When you hung up and redialed it worked fine.

It wasn’t a big problem, more of an annoyance, but I couldn’t really find any solution until today.

I was reading through the admin manual for the phone and found a setting which I’ve changed which seems to have fixed our problem.

Before I explain what I did I should explain how our system is laid out. The asterisk box is actually in our data center a few hundred miles away, so we connect via NAT through 2 firewalls. The assorted issues dealing with that were relatively easy to solve. This was my last remaining “bug”.

Anyways, the solution I found was this:

  1. Log into the web admin page for the phone.
  2. Select “admin” option
  3. Select “advanced” option
  4. Select the ext you are having problems with (in this case ours was 1)
  5. under “NAT Settings” there’s a “Nat keepalive message” which probably says “$NOTIFY”
  6. Change this to “$REGISTER” (without quotes).

This seems to have the effect of re-registering the phone on nat timeout, rather than just pinging it.

Just wanted to share this with everyone!