Registration being lost over VPN

I am running Asterisk x86_64.
The phone in question is a Polycom Soundpoint 301 with SIP version
Our main office, where the Asterisk server is connected to the internet via a Linksys RV042 local net is the router’s local address is

Our remote office where the phone that I’m having the issue with is connected to the internet via a Linksys RV016 local net is the router’s local address is

The two offices are joined via a gateway to gateway tunnel.

The remote office has a linux server running DHCP with option 66 and running an ftp server hosting the provisioning files for the phones.

The first time I configured the phone, it worked just fine for a few days then it wouldn’t register anymore.
After reformatting the phone, it came back up and worked for a few weeks, then wouldn’t register anymore, rebooting and reformatting did not work.
I provisioned another phone with the same settings, and then it worked for two days, then it wouldn’t register anymore.
In the sip.cfg, I have that extension configured to allow traffic from the remote office’s subnet.

The phone can place calls out, but will not ring. A packet capture of all the traffic to the asterisk server records RDP and SIP data for a calls placed by the phone, but no registration attempts. A user at that office confirms that the STATUS->LINES->LINE INFO on the phone’s menu has no registration, but has the correct ip address for the Server-1 field.

Sorry about the small novel, but this problem has been kicking my :open_mouth: on and off for a couple of weeks now, and if anyone out there can help me, they are going to need a boatload of info.

I’ve fought many a battle with the Polycom’s. If you want to send me a password-sanitized copy of all your polycom config files, I’ll be happy to take a look at them.