Register problem to Provicer

I have problem with the registration from my Asterisk server on the Provicer server.

The gave an IP address and they told me I need to sent an invite to their proxy server without sending a username an password but Asterisk doesn’t let me do that and the provider is not willing to create a username.

This is what I did:

I have tried to register like this:

I think I should not user register att all and have tried only to configure a sip trunk like this:

then route my extensions to this trunk.

Both situation does not result in a registration.

Anyone an idea what is going wrong?

I don’t understand how you can say that they are not wiling to give you a username, when you say you used a usename in the register.

You need to provide SIP traces so we can understand what is going on.

I don’t know if this is just the result of truncating the information you provided, but insecure=invite is meaningless, if harmless, if no secret is specified.

Thanks for your answer,

Sorry, I see a typo , I mean that I do not need to sent a Username/password, the provider told me that an INVITE to the peer IP address is enough but the config : does not work.

Do I need to configure this in de SIP trunk config?

Register without a username doesn’t make much sense.

I assume they are authenticating you by a fixed IP address, in which case you don’t need register at all.

You definitely need to provide sip traces.

Thanks David! and I think this is the log you mean?

The right log, but this part of it relates to a local DIgium phone, and is incomplete.

I think this is the one I I need: setup call and routing

Although the source endpoint lookup failure message is a custom one, I guess it means that they don’t accept your IP address or the From: URI.

What happens if you try to register (the response to the REGISTER request).

It look like you are right, they change something in their Firewall , but its still not ok.

When I try to call a number there is no dial tone but in the log file I see that Asterisk tries to reacht the remote for 30 seconds which I have specified in the extension file…

My provider informed me that I do a Invite request on wrong port, my sip trunk config is like this

the log from the provider shows this, any idea why ist request an invite on the wrong port?

Router trying to be clever? Disable any SIP support in the router.

Cool , thanks a lot David for all and the last answare you have solved my issue, I am really appreciated your help!!! :smiley:

I am able to setup calls and speak with the person on the remote site but there is one issues, I dod not here I dial tone and asterisk is complaining a " Familie miscmatch"

With SIP, dial tone is generated by the phone before Asterisk knows there is a call.

The address family thing will be an IPv4 IPv6 conflict.