[Resolved] sip - do not try to register?

Hello
Asterisk 1.2
In my sip.conf:

register => user01:pass@sip.provider.com

[trunk_ipfon]
secret = pass
type = peer
username = user01
fromuser = user01
host = sip.provider.com
fromdomain=sip.provider.coml
context = DID_trunk_1
insecure = very
disallow = all
allow = ulaw
allow = gsm
allow = ilbc
allow = g726

But from console:
pbx2*CLI> sip show registry
Host Username Refresh State

Shows nothing. Trunk is not even tried to be registered.

Why ?

Thanx

I have never set my trunks up the way you have done it, so i am not sure if that config would work, i most likely does and your problem could be something else.

How ever this is the way i generally set our up:

[Carrier]
type=peer
host=XXX.XXX.XXX.XXX (Or put the Uri in here)
fromdomain=XXX.XXX.XXX (Best of to use an IP address here if at all possible, if not then just use the Uri)
disallow=all
allow=ulaw
allow=alaw
allow=g726
; allow=g729
; allow=g723
; allow=gsm

I have the list of CoDec’s there just in case we need to change, i just then remark out the ones i don’t want to use. Also i have never put in all that extra stuff in there… Do you need it?

I can understand putting in the user name, from user and the secret as that is usually needed, however we probably connect up differently to you, since we run on Static IP"s and the carrier only authenticates via IP through their Radius, we don’t need that extra stuff.

My Suggestion is to go over all your user name and password and make sure you have nothing in there that is case sensitive.

Cheers,

David.

Thanx, i removed all unnececary stuff.
The problems was that my registry line was outside of [general] section.

Excellent, if it is all fixed, do you mind editing the title so it now says [Resolved] it helps with keeping the forums up-to-date and clean.

If it ain’t resolved then disregard what i said :smiley:

Cheers,

David.