Queued call is sending callwaiting tone to Agents!

I have my Agents and Queues in a Realtime MySQL DB!

When I’m sitting in a call that got from the Queue and another
call is placed in the queue I get the callwaiting tone!

This is getting very troublesome when it does this for every
call that gets placed in the queue!

How do I disable the tone?

I have tried with “ringinuse=no” for the queue, but no luck!

Set the sets to disable call waiting

Ian

Hi Ian and thanks for your reply!

But i’m sorry, i’m not sure what you mean by:

Are we talking about the queue or agents?

Hi we are talking about your physical handsets.

Ian

Hi Ian and thanks for your reply!

Ok, then I understand!

I have a PAP2T-NA and I found two parameters that i’m not sure which one to change!

Do you Ian or anybody else know the difference between these two?

Under the Line 1 and 2 tab

Call Waiting Serv

Enable Call Waiting Service.
The default is yes.

Under the User 1 and 2 tab.

CW Setting

Call Waiting on/off for all calls.
The default is yes.

Or should I change something else?

you should also look at the queue parameters and make sure “ringinuse=no” to prevent the queue from even trying to ring extensions that are already in use handling queue calls.

Hi mudslide567 and thanks for you reply!

The conf file tells me this:

[code]; Ring Inuse
; If you want the queue to avoid sending calls to members whose devices are
; known to be ‘in use’ (via the channel driver supporting that device state)

; uncomment this option. (Note only the SIP channel driver currently is able
; to report ‘in use’.)
;
; ringinuse = no
[/code]
But i’m using RealTime and I cannot use “yes” or “no” there.

Table queues in database asterisk

ringinuse tinyint(1)

The only value I can have there is numeric, in my case it is 0 (zero)

I am going to guess that ringinuse = 0 in the database is equivalent to ringinuse = no in the config file…but you probably should check documentation to confirm.

you did not mention which version of asterisk you are using but there is a second problem with asterisk 1.4 which is that depending on how your queue is set up, it may not be able to see that the extension is in use. you should probably check this by running queue show {queue-name} from the CLI while you have an agent talking…and see if the extension shows up as “In Use”. If it does not show up as in use, you have another whole set of problems to worry about.

Hi mudslide567 and thanks for your reply!

I’m running Asterisk SVN-branch-1.4-r181990

And yes, on a incoming call I get the “In use” for the Agents!

Agent/2001 (SIP/2001) (realtime) (In use) has taken 15 calls (last was 670 secs ago) Agent/2002 (SIP/2002) (realtime) (Ring+Inuse) has taken 23 calls (last was 825 secs ago) Agent/2003 (SIP/2003) (realtime) (paused) (Not in use) has taken no calls yet
It looked like this when I:

Made a direct call to Agent/2001 with one phone.
Another person called in to the Queue and Agent/2002 answer that call.
Next I called in to the Queue with another phone and was put in Queue

Now it seams like I have solved this by changing “Call Waiting Serv” to no
in my PAP2T-NA. But I have hoped that I in Asterisk could disable the
Call Waiting tone for call only coming from a Queue, not a direct call!

With this I think I cannot use “Call Waiting” at all on the phone connected
to this PAP2T-NA box!