Question referred from another forum

https://forums.centos.org/viewtopic.php?f=54&t=80460

Hope it will be solved here atleast. Please consider and Kindly do the needful…

With Hope,
Prabhakaran

I don’t understand the question or the problem.

I am trying to make, make-install and finally config the Asterisk 20.5. source.
The make is with done normal privileges (astmin is the username)
But the make-install and the config has to be done with privileged account (sudo)
Initially the config was failing and advised me to install chkconfig. I installed chkconfig.
But after the config the system has to show a list config files made. But its not. what could be the problem. Please Help.
With Hope,
Prabhakaran

Dear Members, Sincerely requesting you all to put some light on this issue. Please consider and Kindly do the needful. Thanks

With Hope,
Prabhakaran

…this is a community forum where noone is obligated to respond or help with issues, asking for “escalation” like this 2 hours after filing is likely to just push people away

Sorry colp. Not like that. Work at stake. Thats why I asked for Help. Acutally this issue makes me wait for more than a week. Anyway, I understand. What you people can do for my urgency. I completely understand. Here after, I will not persuade for immediate help. Sorry this time.

Otherwise, Is there a way to see the source code of that config file?

config is not a file. Asterisk is open source, so you can see everything. The advice on the other forum that it can be done from an unprivileged account is wrong.

Thanks to David for replying. I my case, what to do if I doubt these files are not made as a result. Please guide. Thak you.

How to supply ‘verbose’ to it or Is there a log file for the same? Please confirm. Thanks :slight_smile:

That’s a Linux question. I can’t remember what options exist, and I’ve never, personally, had problems with this part of the installation.

1 Like

My linux knowledge is very rudimentary, but why do you use sudo at all?
I have asterisk on Centos and compiled it with a root (changed to root with “su” command), then executed chown on the etc/asterisk directory to change the owner to the asterisk user (astmin in your case). Asterisk runs under asterisk user. Should be alright.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.