Installation as Non Admin User


#1

Hi,
I tried to install Asterisk as non admin user.
The first step in the Readme the “make” brought no errors
but the second step I tried the “make install” and then the program stops becaus of I am no admin. After that I copied the asterisk executebale to my local Home dir and now I need an Config file I need to start the programm with ./asterisk -C
Someone knows where to find example configfile for tihs case ?

thx much SquadWuschel


#2

Hi SquadWuschel,

Check where Asterisk tries to create his pid file. You have to change the ASTVARRUNDIR in the Makefile before you compile it, ex :
ASTVARRUNDIR=$(INSTALL_PREFIX)/var/run/asterisk

You may want to check this out :
http://www.voip-info.org/wiki-Asterisk+non-root

Have fun.


#3

You can also edit the make file to allow asterisk to run as a specific user, ie your user and you shouldnt have any trouble connecting to it or starting it.


#4

thx much for the answers i will try it next week when I am back at my studying place :smile:

thx much SquadWuschel

(one other question the link you liked voip-info.org/wiki-Asterisk+non-root in there they speak about

Asterisk needs read permission for these directories and their contents:
/etc/asterisk

but I am just a normal User i don’t have any Root permissions and I need to install it the root can’t help me with giving any rights I just have persisions in my homedir, so can I Use the way they speak about in the link or will I get problems)