Problems with voipbuster


#1

Hi,
I need a little help to configure asterisk with voipbuster.

This is a part of my iax.conf

register => cyro:****@iax.voipbuster.com

[voipbuster]
type=peer
host=iax.voipbuster.com
username=cyro
secret=***
notransfer=yes
context=default
qualify=yes
disallow=all
allow=gsm


and this is a line in my extensions.conf

exten => 4321,1,Dial,IAX2/cyro@voipbuster/0039091343749

and this is what happens…

Asterisk Ready.
– Registered to ‘213.61.187.156’, who sees us as 82.52.191.98:4569
Aug 17 04:12:50 NOTICE[1319]: chan_iax2.c:5675 socket_read: Peer ‘voipbuster’ is
now REACHABLE!
– Executing Dial(“SIP/burp5fd4”, “IAX2/cyro@voipbuster/0039091343749”) in
new stack
– Called cyro@voipbuster/0039091343749
– Call accepted by 213.61.187.156 (format gsm)
– Format for call is gsm
– Hungup ‘IAX2/voipbuster/4’
== No one is available to answer at this time
Aug 17 04:13:19 WARNING[1327]: pbx.c:1948 ast_pbx_run: Timeout, but no rule 't’
in context ‘default’

Well… voipbuster seems to accept the call… but after some seconds it hungups…

Can someone help me ? Is someone using voipbuster with asterisk?

thank you.


#2

… I mean… do you think this is a voipbuster problem or my setup is wrong?


#3

I think that this this is a voipbuster problem.

I am using voipbuster via SIP and get these messages all the time.

Aug 17 14:43:29 VERBOSE[20517]:     -- Got SIP response 503 "Unavailable" back from 213.61.187.146
Aug 17 14:43:29 VERBOSE[7062]:     -- SIP/voipbuster-2ec1 is circuit-busy
Aug 17 14:43:29 VERBOSE[7062]:   == Everyone is busy/congested at this time

The network of voipbuster seems overloaded. Just try many times, and finally you will get through…

I am using a macro with a loop in my dialplan to automatically try many (max. 100) times (with 2 seconds delay between the tries).

exten => _0Z.,1,Macro(call-sip-ext,0031${EXTEN:1}@voipbuster)
exten => _00.,1,Macro(call-sip-ext,${EXTEN:0}@voipbuster)

....
...
[macro-call-sip-ext]
exten => s,1,SetVar(Loop=0)
exten => s,2,Dial(SIP/${ARG1})
exten => s,3,SetVar(Loop=$[${Loop} + 1])
exten => s,4,Goto(s-${DIALSTATUS},1)

exten => s-NOANSWER,1,Hangup
exten => s-CHANUNAVAIL,1,Hangup
exten => s-BUSY,1,Hangup

exten => s-CONGESTION,1,Wait,2
exten => s-CONGESTION,2,GotoIf($[${LOOP} > 100]?s-CONGESTION2,1:s,2)

exten => s-CONGESTION2,1,Hangup

exten => _s-.,1,Playback(something-terribly-wrong)

#4

or the number you dial is wrong, or they dont have enough capacity…


#5

well.
I made another account with voipbuster and that worked with the same
configuration! (just changed the username)

The old account still doesn’t work. (and this is not a login problem, because as you can see from the logs the call is accepted).

I can use the old account only from their softphone.
I don’t know why!
Btw… with the new one all is ok…

thank you for the answers :smile: