Problems with voice-mail envelope

Good evening,

I’m kinda puzzled with my Asterisk server, for some reason when I access my voice-mail and I press 1 to hear my new/old message it says “1st message, message from phone number XXXXXXX” then it plays the voice-mail message , after I listen to the message I press “3” (advanced options) then “3” (hear the message envelope) I get “message from phone number XXXXXXX”

on my voicemail.conf file I have the option : saycid=yes and envelope=yes , if I configure saycid=no I don’t hear the prompt “message from phone number XXXXXX” anymore, but no matter I have envelope=yes/no it doesn’t say the date and time the message was received, I even tried to upgrade from Asterisk 11 to Asterisk 12 but it still doesn’t say the date and time the message was received. I can only see the date and time when I receive a copy of the message on my e-mail

I know there is a way to play this information before the message, I remember it used to say “you have 1 new message…” I pressed “1” and I would get “1st messafe received at XXam/pm from phone number XXXXXX” , and I also checked the Asterisk CLI and it’s not returning any kind of error such as file not found or something…

Is anyone familiar with the Asterisk voice-mail system ? I tried searching on google but it seems like I’m the only one with this problem…