Problems with te110p and e1


#1

Hi all, not sure of where to post this question, tried in developer section but I think that may be wrong place.

Apologies to moderators for reposting here

The Problem

I recently plugged in an E1 to a te110 and am getting the following error sequence
Finally got the Brisbane DIDs in and I can connect with them but the call is a little crackly and I get kicked because the channels reset after clearing alarms

Am having a problem with and not sure if it is related to The driver version, config or something else
(Configs Below)
The error sequence I get is

-------Lots of these-----
Dec 6 09:42:04 NOTICE[23753] chan_zap.c: PRI got event: HDLC Abort (6) on Primary D-channel of span 1
Dec 6 09:42:06 NOTICE[23753] chan_zap.c: PRI got event: HDLC Abort (6) on Primary D-channel of span 1
Dec 6 09:42:06 NOTICE[23753] chan_zap.c: PRI got event: HDLC Abort (6) on Primary D-channel of span 1
Dec 6 09:42:07 NOTICE[23753] chan_zap.c: PRI got event: HDLC Abort (6) on Primary D-channel of span 1
Dec 6 09:42:07 NOTICE[23753] chan_zap.c: PRI got event: HDLC Abort (6) on Primary D-channel of span 1
-------Then for channels 1 to 31----------
Dec 6 09:44:22 WARNING[23754] chan_zap.c: Detected alarm on channel 30: Yellow Alarm
Dec 6 09:44:22 WARNING[23754] chan_zap.c: Unable to disable echo cancellation on channel 30
Dec 6 09:44:22 WARNING[23754] chan_zap.c: Detected alarm on channel 31: Yellow Alarm
Dec 6 09:44:22 WARNING[23754] chan_zap.c: Unable to disable echo cancellation on channel 31
---------Then--------
Dec 6 09:44:22 NOTICE[23753] chan_zap.c: PRI got event: No more alarm (5) on Primary D-channel of span 1
Dec 6 09:44:22 WARNING[23753] chan_zap.c: No D-channels available! Using Primary on channel anyway 16!
-----Then all alarms are cleared and channels reset with----------
Dec 6 09:44:22 NOTICE[23754] chan_zap.c: Alarm cleared on channel 1
Dec 6 09:44:22 NOTICE[23754] chan_zap.c: Alarm cleared on channel 2
Dec 6 09:44:22 NOTICE[23754] chan_zap.c: Alarm cleared on channel 3
Dec 6 09:44:22 NOTICE[23754] chan_zap.c: Alarm cleared on channel 4
Dec 6 09:44:22 NOTICE[23754] chan_zap.c: Alarm cleared on channel 5
Dec 6 09:44:22 NOTICE[23754] chan_zap.c: Alarm cleared on channel 6

--------Then this starts over again--------
Dec 6 09:44:23 NOTICE[23753] chan_zap.c: PRI got event: HDLC Abort (6) on Primary D-channel of span 1
Dec 6 09:44:24 NOTICE[23753] chan_zap.c: PRI got event: HDLC Abort (6) on Primary D-channel of span 1
Dec 6 09:44:25 NOTICE[23753] chan_zap.c: PRI got event: HDLC Abort (6) on Primary D-channel of span 1

Am using Kernel 2.4.27 SMP
How do I tell what version of Asterisk? (earlier than 1.2, latest cvs version of 1.0 i think)
Version of Zaptel is 1.0.7

E1 is Australian Primary rate

–Am loading
modprobe wcte11xp
modprobe zaptel
/sbin/ztcfg

zttool reports all good
zttest better that 99.99

ZAPTEL.CONF
span=1,1,0,ccs,hdb3,crc4
bchan=1-15
dchan=16
bchan=17-31
defaultzone=au

ZAPATA.CONF
[channels]
signalling=pri_cpe
switchtype=national
echocancel=yes
echocancelwhenbridged=yes
echotraining=400
callerid=asreceived
group=1
channel => 1-15,17-31
rxwink=300

Can anyone help??
Have u seen this error before?
Was wondering what if version of asterisk and zaptel is imprtant here?

Thanks
Norm