Problems installing asterisk


I’m having a problem installing asterisk, but I’m not getting it.

I will leave the images attached.

I’m using the command: ./configure --libdir=/usr/lib64 --with-jansson-bundled but it’s returning an error.

If anyone can help me, I’d appreciate it.



It attempted to download the file from Github and failed. You can do as the error says and re-run configure with NOISY_BUILD to see if it provides further information.

sorry, but I’ve been stuck in this part for a few days, what error is he reporting that I should repair?

I ran it again with NOISY_BUILD=yes, I will send the message that returned as an attachment


Can you manually download it? Does that work? How exactly did you pass NOISY_BUILD=yes?

how do i download it manually?

attached how I ran NOISY_BUILD=yes


You can use “wget” if installed, or “curl”. The URL is in the messages.

You should also be able to just stick the URL into a web browser, although you may then have the problem of copying it from the download machine to the target one.

If you had provided the screen the output as plain text, I would have tried that myself.

I managed to install directly from the link, as mentioned, but the asterisk symbol did not appear stating that it completed the asterisk installation.

attached the image.


I have no problem doing this, I can copy and paste directly from the web by putty.


I would not have expected it to, as all you have done is to download, and probably not even into the right directory. You haven’t attempted to configure and build Asterisk.

All the test was trying to do is check whether it was downloadable, to your machine.

Did it take a long time to download? You might be exceeding a timeout. Otherwise, you will need detailed debugging to work out what is going wrong.

Assuming you still have jansson-2.14.tar.bz2.3 sitting in that directory…try this:

rm /tmp/jansson-2.14.tar.bz2
mv jansson-2.14.tar.bz2.3 /tmp/jansson-2.14.tar.bz2

Downloading the file doesn’t automatically make the process start over, nor does the configure script look for it where you downloaded it. Putting the file, with the correct file name, in the proper directory and running configure again should find it.

from what I’ve verified, the files: jansson-2.14.tar.bz2.2 and jansson-2.14.tar.bz3 are still in the directory: /usr/src/asterisk-20.0.0, in which case I should remove 2.14.tar.bz2 .2 and move only 2.14.tar.bz3 to /tmp/ ?

rm /usr/src/asterisk-20.0.0/jansson-2.14.tar.bz2
mv jansson-2.14.tar.bz2.3 /tmp
cd usr/src/asterisk-20.0.0: ./configure

inside /tmp I don’t have any .tar file

image attached

Uploading: Capturar2.PNG…
Uploading: Capturar.PNG…


I believe that the problem is not the connection case, when I downloaded other files it was without any problems.

The .3 is a tie breaker inserted by the downloader. It should not be included in the final name, which should end in .bz2.

so in this case I should transfer to /tpm only jansson-2.14.tar.bz2.2 from my /usr/src/asterisk-20.0.0, that would be ?

sorry if i didn’t understand very well

You should transfer the complete version of the file, under whichever name it is actually stored, to /tmp/jansson-2.14.tar.bz2. Note that I haven’t analysed the scripting well enough to be sure that is the correct directory when pre-downloading, or that that is the correct way of doing so.

The scripting does check the integrity of the download, so one possibility it that a failed download wasn’t overwritten by the second attempt (a .2 or .3 version was created, instead), and simply removing the failed download and running configure may be enough.

Generally, this part of the process should work, as long as your have good connectivity and the file server is working a the time, so people generally won’t have experience of having to fix things up manually.

have to create another account, because that one exceeded the message limit of the first day hahahaha

I deleted the other versions and moved only the correct one to /tmp but there was still an error in the installation.

how can i copy the script for you to take a look at?


OK so you’ve passed the issue with Jansson but are having the same issue with pjproject. Follow the same steps you did with Jansson for pjproject-2.12.1.tar.bz2. The URL is

it worked my friend

resolution: after installing manually (inside /usr/src/asterisk-20.0.0/)
wget and wget pjproject/2.12.1/pjproject-2.12.1.tar.bz2 , moving the two files that generated .tar.bz2 to /tmp , I ran the command again: ./configure --libdir=/usr/lib64 --with- jansson-bundled and I was able to complete the asterisk installation