Problem with SIP on the outside of my network

Hi all,

Here is my problem, I am able to connect X-Lite and make calls internally on my network. When I Put X-Lite outside my network it connects and says ready and shows my Username correctly. I then press a key and on asterisk CLI I see chan_sip.c:11244 handle_request: Unknown SIP command ‘PUBLIST’ Form and my asterisk IP address, I opened port 5060 on my firewall. any ideas?

Thanks for all the help

SIP signaling: Ports 5060 to 5070
RTP audio: Ports 8766 to 35000

Hi Rusty,

Thanks for the reply, I will check the firewall settings I am not using nat to connect to asterisk… its a hole.

In rtp.conf I have found
Are those port numbers? If yes, should they be opened in firewall instead of 8766 to 35000?

Also, in my firewall I have just 5060 udp opened and It always worked. In which cases “sip signaling” with other 10 ports will be used?

I checked the firwall rule and everthing checks out. I am not using nat at all I have open the the port. I am not sure why Asterisk doent understand the SIP commands outside the network.

if you’re not using NAT your Asterisk MUST have a public IP address. is this the case? how are connections from outside the LAN getting routed to Asterisk inside the LAN?

Hi Geoff,

Yes my asterisk server has a public Interface, I am using my server as a firewall, mail server and asterisk server. I two Interface cards one private and one public. I can make SIP calls inside my network from one pc to the other on my LAN I have connected to the Digium Test server as well. When I put the SIP phone on my external IP It connects and says ready and gives me my username as an extention I created, while watching the CLI evertime I hit a digit it send a responce Jul 28 12:30:38 NOTICE[10290]: chan_sip.c:11244 handle_request: Unknown SIP command ‘PUBLISH’ from ‘’

hope this answer the question

Am I missing something? I stoped the firewall open to the world and still get the same answer… Is there a place to configure external SIP Vs Internal ?

starnge phnoe is sending SIP command ‘PUBLISH’ , can You give more info about this phone ?
can You intall x-lite and try to comunicate with * box ?

i agree with fdragowski, try with a different phone.

then turn on sip debugging (‘sip debug’ on the CLI) and try to decipher the SIP messages, they might give you a clue. i’ve never set up * with two NICs, i wonder if you might need to specify your external IP (externip=xxx in sip.conf.) because if * is sending it’s internal IP address to the external phones, well that obviously won’t work.

You should visit the following thread to check out your port configs; … ight=drwho
I think the admin guys should make the thread a sticky so anyone with a firewall/NAT issue can first check it out first before posting the same issues over and over again only to be told the same solutions or referred to the same thread(s).

why ? a link the the wiki SIP+NAT page would be better, that way multiple people can contribute to it rather than have one person edit it.

i dislike seeing forums with loads of stickies, mainly because people don’t read them anyway.