Problem with outgoing calls inasterisk with ooh323


I have the following architecture. I have an h323 gateway which is Cisco Call Manager, an asterisk instalation with ooh323 as h323 client to call manager. I attach the extension.conf and ooh323.conf. Incoming calls are working perfectlly. The problem is in outgoing. When I place a call in asterisk then the outside phone rings but when I reply the VoIP phone doesn’t understand it and continues to ring. Help would be grateful…



; Outgoing calls.
; Every 10 digit number is passed to iCall peer.

exten => _XXXXXXXXXX./_5103X,1,Dial(OOH323/${EXTEN}
exten => _XXXXXXXXXX./_5103X,2,Set(CALLERID(num)=‘3024’)
exten => _XXXXXXXXXX./_5103X,3,Playback(number-not-answering)
exten => _XXXXXXXXXX./_5103X,4,Hangup
exten => _XXXXXXXXXX./_5103X,102,Playback(the-number-u-dialed)
exten => _XXXXXXXXXX./_5103X,103,Playback(is-currently)
exten => _XXXXXXXXXX./_5103X,104,Playback(unavailable)
exten => _XXXXXXXXXX./_5103X,105,Hangup

; Incoming for real number
exten => 2810393024,1,Dial(SIP/51031,45,Rtj)
exten => 2810393024,2,Playback(number-not-answering)
exten => 2810393024,3,Hangup
exten => 2810393024,102,Playback(the-number-u-dialed)
exten => 2810393024,103,Playback(is-currently)
exten => 2810393024,104,Playback(unavailable)
exten => 2810393024,105,Hangup

exten => 3024,1,Dial(SIP/51031,45,Rtj)
exten => 3024,2,Playback(number-not-answering)
exten => 3024,3,Hangup
exten => 3024,102,Playback(the-number-u-dialed)
exten => 3024,103,Playback(is-currently)
exten => 3024,104,Playback(unavailable)
exten => 3024,105,Hangup


exten => 51031,1,Dial(SIP/51031,45,Rtj)
exten => 51031,2,Playback(number-not-answering)
exten => 51031,3,Hangup
exten => 51031,102,Playback(the-number-u-dialed)
exten => 51031,103,Playback(is-currently)
exten => 51031,104,Playback(unavailable)
exten => 51031,105,Hangup

include => parkedcalls
include => internal


; Or a conference room (you’ll need to edit meetme.conf to enable this room)
exten => s,1,Playback(invalid)
include => local

;Dialplans for registered users
;Internal calls
include => default
include => internal

;External calls
include => default
include => internal
include => icall-nikosaei


;Define the asetrisk server h323 endpoint

;The port asterisk should listen for incoming H323 connections.
;Default - 1720

;The dotted IP address asterisk should listen on for incoming H323
;Default - tries to find out local ip address on it’s own

;Whether asterisk should use fast-start and tunneling for H323 connections.
;Default - yes
;H323-ID to be used for asterisk server
;Default - Asterisk PBX


;CallerID to use for calls
;Default - Same as h323id

;Whether this asterisk server will use gatekeeper.
;Default - DISABLE
;gatekeeper = DISCOVER
;gatekeeper = a.b.c.d
gatekeeper = DISABLE

;Location for H323 log file
Default = /var/log/asterisk/h323_log

;Following values apply to all users/peers/friends defined below, unless
;overridden within their client definition

;Sets default context all clients will be placed in.
;Default - default
;Sets rtptimeout for all clients, unless overridden
;Default - 60 seconds
;rtptimeout=60 ; Terminate call if 60 seconds of no RTP activity
; when we’re not on hold

;Type of Service
;Default - none (lowdelay, thoughput, reliability, mincost, none)

;amaflags = default

;The account code used by default for all clients.

;The codecs to be used for all clients.Only ulaw and gsm supported as of now.
;Default - ulaw
; ONLY ulaw, gsm, g729 and g7231 supported as of now
disallow=all ;Note order of disallow/allow is important.

; dtmf mode to be used by default for all clients. Supports rfc2833, q931keypad
; h245alphanumeric, h245signal.
;Default - rfc 2833

port = 1720
type = peer
context = external-nikosaei
dtmfmode = h245signal
faststart = no
h245tunneling = no
;disallow = all
;allow = g729

I had the same issue with my carrier that uses Cisco. I think I needed to set
faststart = yes
h245tunneling = yes

Ask your carrier to run some tests on the cisco switch to see what the problem is.


My carrier told me to change these settings. But I still can try to change them and see if that works. Any other ideas???