Problem w/ remote systems recognizing DTMF

I have asterisk 1.4.26 running via astlinux with a Sangoma a200 board (2x FXO + 2x FXS) and Grandstream GXP2000 phones. We have noticed some instances where DTMF tones are not recognized by remote systems. Specifically we have this problem with a particular conference call service keying in the PIN (says its not recognized) and even with an IVR used to claim unemployment benefits (won’t recognize keyed in SSN). In both cases, we can accomplish these calls using a cell phone. All the calls are run through an FXO port on the Sangoma card. These are the only two instances that we are aware of where we have the problem; DTMF seems to be recognized OK by other remote systems.

At this point, I’m not sure if this is a configuration issue with asterisk, sangoma, and/or grandstream. Any suggestions on a strategy to attack this problem would be greatly appreciated.

Process of elimination.

Is it one client that can’t do it ? Is it only all the calls from the PSTN ?

This behavior has been reproduced when making calls from two different phones, which doesn’t surprise me because the configuration of all the Grandstream equipment is very similar (only different extension info).

The problem occurs on outbound PSTN calls via an FXO channel to specific remote endpoints (see original post for details). There has never been any DTMF issues with this system controlling the local IVR, or calling extensions, etc.

I am also having problems with this. The federal EFTPS system doesn’t recognize input from Grandstream BT200 phone. We are using VoIP with and not the POTS lines. Asterisk 1.4.26 also.

All other systems work: banks, auto-attendants, tech support…

My solution was to split the fax line and throw a basic phone on there. ::shrug::

That’s very interesting! Did you have an opportunity to see if the problem occurs with a phone from a manufacturer other than Grandstream? While I don’t have the BT200, I imagine that the firmware in that device and the GXP2000 would be similar. Did you log any support calls with Grandstream on this subject? If so, any response from them?

Does anyone else seem to believe that this is a Grandstream problem rather than an issue with my asterisk/sangoma/astlinux config?

I haven’t tested it much as the EFTPS is not a system you just call up and mess around with as I understand. I lean towards PBX issue, but it certainly could be Grandstream phones in particular. They all have the same odd web interface / settings.

I wanted to try this one and check the “in-audio” which I don’t normally use:

I believe my phones are configured for “in-audio” and “via SIP info”, and I have not enabled “via RTP (RFC 2833)”. I will verify these settings tonight.

Which setting for send DTMF have you used when you encountered this problem?

If I don’t check RTP then my phones won’t even register. I have RTP checked and audio and SIP unchecked. In my experience it doesn’t cause any problems to check the ones that you don’t need.

OK, I need to do more testing, but the solutuion seems to be using RFC 2833 to generate the DTMF. On the GXP2000 I select “via RTP (RFC 2833)” and in sip.conf I edited it to include “dtmfmode=rfc2833” for the corresponding extension definition. Now the DTMF seems to be recognized by the remote IVR, however the tones sound a little strange via the handset (almost like two tone for each keypress). This is a minor issue, but wondering if anyone might know what is going on here.

try dtmf=inband in your sip.conf, I have 5 grandstream gxp2000’s and I dont have a problem calling anywhere, I am up to the latest firmware on all of them as well.