Problem sending a fax with Asterisk - TIF file format?


#1

I’m running asterisk 1.0.5 with the spandsp patch applied and I am trying to send a fax. For some reason, it just doesn’t work with the TIF file I’m using. To be specific, asterisk dies and the receiving fax machine answers the call, and then reports ‘receive failed’. I have tried this with one other TIF file (from an old fax job) and that seems to work, so I’m happy that the system is set up properly. So it looks like the problem is with the TIF itself. What are the rules for preparing a tif for faxing? what should be the dimensions/resolutions/compression etc? Is this documented anywhere please?

thanks all,

christo


#2

Try searching info for the libtiff and check whether you’re runing the last available version.


#3

I appear to have fixed it - It turned out that altho I couldn’t open the TIF in any image viewers, if I just send it out anyway, it seems to work just fine. I have also discovered that Imagemagick will convert to fax format, altho I’ve not tried sending one yet…

christo