Problem installing * on Fedora Core 4


I’m actually using a server based on FC4 and when I try to install * it fails.

When starting ‘Make install’ I get the message that I first have to run the config before the make install

I tried to start ‘make install’ but the system tells me it has no config for my OS !

Does somebody have an idea ?
Does * run w/o problem on Fedora Core 6 (I could have another server on FC6).

Thanks in advance

damn those pesky error messages !

have you tried running ./configure in the Asterisk source directory before going any further ?

If you ran out of your original ideas, please read a manual.

Hi there,

I have Asterisk running on FC4 and FC6, however you will need to do the install as follows.

Steps in order:

  1. ./configure
  2. make clean
    3a. make menuselect (Optional, you don’t have to do this)
    3b. make
  3. make install
  4. make samples (Optional again, you don’t have to do this either)
  5. make progdoc (optional Again)

You should have no problems doing the install if you go by the above steps, give it a try and then report back.

Alternatively it may help to read up on some of the tutorials you can find on the voip-info wiki, there is a bucket load of info on there.



isn’t it daft that the README that ships with 1.4 doesn’t include information about using “configure” and “make menuselect” !!

Actually, the menuselect is only mentioned in the UPGRADE.txt file (at least in version 1.4.2).

I know, I should have read all the install files - mea culpa :smile:

Thanks all for your replies !

In the future, I will first read ALL the doc before starting :blush:

I first did ./configure and then… Bingo it worked !