Problem inasterisk annoyed me soo much & wish to solve it!

Hi ,

i have an elastix server based on asterisk [color=#FF0000]asterisk-1.8.7.0-0[/color]
im using hardware [color=#FF4000]Span # 1: ATCOM -1600P/16 “ATCOM AX1600P/800P Board 17” (MASTER)[/color]
i have 8 analog lines connect to my server from PSTN.

[size=150]My Problem:[/size]
the problem is saome times my pstn lines hanged for long time , and in this case i have to unhang it manually .
some times the line cant be unhanged and i must go to linux console and type $amportal restart to solve this hang line
Hint :
here is the image links if not clear below :
#####################################################
www9.0zz0.com/2012/07/19/07/806676536.png
www10.0zz0.com/2012/07/19/07/309112944.png
www10.0zz0.com/2012/07/19/07/746702362.png
######################################################

i thought in firstly that the problem in fop1 , but after installing fop2 the same problem exist and this is frequent and very hanrmful . becuase it hang an extentin with external line and cause my lines to be busy for long time!!!

i searched alot in the internet and didnt find a solution to this issue , i could finally recognize that this is an asterisk issue .

i will put a print screen about the problem is both fop1 and fop2 and wish to demonstrate my problem well:
as u see in fop1 the line hanged for more than 4 hours !!

as u seen in fop2 the line hanged for more than 8 hours !!

as u see here that the extension is hanged and cant be unchanged from fop2 and only solved when i reload asterisk by $amportal restart


im really hurtled and wish somebody help me how to solve this issue >

this is my 1st post and wish to give me a result
i enclosed my system specifications below :

with my best regards to asterisk forums

#################################################################
Kernel
Linux(i386)-2.6.18-238.12.1.el5

Elastix
elastix-2.2.0-14
elastix-firstboot-2.2.0-5
elastix-system-2.2.0-14
elastix-email_admin-2.2.0-9
elastix-vtigercrm-5.1.0-8
elastix-extras-2.0.4-4
elastix-asterisk-sounds-1.2.3-1
elastix-simmrate-2.2.0-10
elastix-my_extension-2.2.0-5
elastix-agenda-2.2.0-5
elastix-a2billing-1.8.1-16
elastix-addons-2.2.0-4
elastix-im-2.0.4-2
elastix-pbx-2.2.0-14
elastix-security-2.2.0-7
elastix-reports-2.2.0-6
elastix-fax-2.2.0-4
RounCubeMail
RoundCubeMail-0.3.1-10
Mail
postfix-2.3.3-2.3.el5_6
cyrus-imapd-2.3.7-12.el5_7.1
IM
openfire-3.5.1-2
FreePBX
freePBX-2.8.1-7
Asterisk
asterisk-1.8.7.0-0
asterisk-perl-0.10-2
asterisk-addons-1.8.7.0-0
FAX
hylafax-4.3.10-2rhel5
iaxmodem-1.2.0-1.1
DRIVERS
dahdi-2.4.1.2-5
rhino-0.99.4-2.rc1
wanpipe-util-3.5.23-1
#################################################################

Hi

Have you spoke to your carrier,? you need to check that you have “disconnect clear signals” or also called CPC “Calling Party clear” signals enabled on this line. im guessing teh hung cals are incoming calls.

One work aroung is to put a max message length in the config for the trunks

Also ast the boards are Atcom Clones you will need to speak to them .

Also your dahdi version is very Old, you need to update it. Do you have enabled the busydetec & busycount settings in your trunks?

[quote=“ianplain”]Hi

Have you spoke to your carrier,? you need to check that you have “disconnect clear signals” or also called CPC “Calling Party clear” signals enabled on this line. im guessing teh hung cals are incoming calls.

One work aroung is to put a max message length in the config for the trunks

Also ast the boards are Atcom Clones you will need to speak to them .[/quote]

hi ,
i will ask about cpc , also i will contact atcom

2ndly , u r right, the problem occurs from callers who make an incomming calls , i note it sometimes when the out caller ring for long period of time without being answered , in this case , line still busy and become hanged !!!
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
about the config of busydetect & detect count i think it is configured well and here is my config from file chann_dahi :
[trunkgroups]

[channels]
context=from-pstn
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
faxdetect=both
echotraining=800
;rxgain=0.0
;txgain=0.0
rxgain=1.2
txgain=2.5
callgroup=1
pickupgroup=1

;Uncomment these lines if you have problems with the disconection of your analog lines
busydetect=yes
busycount=13

immediate=yes

#include dahdi-channels.conf
#include chan_dahdi_additional.conf

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
relative to update asterisk , actually im afraid from this step because i read it may cause conflict .

wish this config helps to troubleshoot .

regards