[Problem] Digium TDM400P - Can't dial Extensions


#1

I have just gotten my asterisk system installed and set up, compiling from source (1.2.5) on a SUSE 9.1 system. When I turn on my phone, I hear a dialtone. As soon as I dial, I get a rapid beep, like I dialed an invalid number. I get the following errors from the CLI in Verbose 10
– Starting simple switch on ‘Zap/2-1’
– Hungup 'Zap/2-1’
Mar 10 21:45:06 WARNING[6413]: chan_zap.c:1586 zt_set_hook: zt hook failed: Device or resource busy

I also tried Channel one with the same results.
zttool and ztcfg show the hardware to be working properly

Zaptel.conf

fxoks=1
fxoks=2
fxsks=3
fxsks=4
loadzone=us
defaultzone=us

Zapata.conf
[trunkgroups]
;define any trunk groups

[channels]
; hardware channels
usecallerid=yes
hidecallerid=no
callwaiting=no
threewaycalling=yes
transfer=yes
echocancel=yes
echotraining=yes

; define channels
context=incoming
signalling=fxs_ks
channel => 3

context=internal
signalling=fxo_ks
channel => 2

Extensions.conf
[internal]
exten => 611,1,Answer()
exten => 611,2,Echo()
exten => 613,1,Dial(IAX2/iaxfwd/613)

[incoming]
exten => 754946,1,Answer()
exten => 754946,2,Echo()

Any Help would be much appriciated. Please remember that it has been several years since I played with linux and I wasn’t all that good to begin with.


#2

If you’re really that much of a beginner, I’d really recommend using asterisk@home…


#3

But then I would remain a beginner forever…I have plenty of time and a renewed need to learn linux…this seems like as good a time as any to learn. I didn’t know much about mechanics until I bought an old CJ-7 and rebuilt it.


#4

not clear on your set up. what kind of modules do you have in the TDM400 and what kind of phone are you using, analog?


#5

that’s just silly. when you’re starting with something, you take a graduate level course? you can’t move up as you learn? as far as your question in general, i see your point, but why should we help someone who IS a rank beginniner but wants to start on 3rd base?


#6

I have a TDM400P with two FXS modules (1,2) and two FXO modules (3,4). I have an analog phone connected to channel 2, though i have tried channel 1 with the correct changes to my config files with the same results. I pickup the phone and hear a dialtone. I dial the extension from my extensions.conf (I’ve tried different extension numbers) and then get the steady beeping sound through the phone. I also get the error messages I posted above from my CLI console. This is only a test environment and I don’t currently have an incoming Pots line to test the FXO modules on. Thanks!!!


Without getting into a long discussions of my motives, I feel I learn better by taking on large projects and working my way through them. I only ask questions when I have been stumped for a long time. I appriciate the advice on switching to asterisk@home, based on my personal situation I have chosen to remain on this course. If you choose to give me no more advice, I understand completely.


#7

have you tried channels 3 & 4? i mean are you sure your settings in zaptel.conf match your card? maybe the FXO & FXS modules are swapped? have you read the book in my signature for clues on proper configuration? i have a TDM400 with one FXO module which worked off-the-bat so don’t have much too experience troubleshooting this error.

when i decided to learn Asterisk I jumped right in and skipped AAH. i think that if you’ve got the time it’s a good way to do it. i am now using AAH and am glad that i know what is going on ‘under the hood’.