TDM400P Not Answering

Hello. I have Asterisk running and have been able to connect internally with an IP phone, connect to the Digium server via IAX, etc. I’m now attempting to get an FXO port running on a TDM400P with no luck.

When I dial in it simply rings. Asterisk never answers. Asterisk doesn’t show anything on the screen. I think I have the configs correct and everything loaded, but am very much an Asterisk noob.

Here’s what I think you’ll be looking for:


fxsks=1 loadzone = us defaultzone=us



callerid="* X400 POTS"<(123) 456-7890>
channel => 1[/code]

lsmod | grep zaptel

zaptel 212004 1 wctdm crc_ccitt 6465 1 zaptel

/sbin/ztcfg -vv

[code]Zaptel Version: 1.4.0-beta2
Echo Canceller: MG2

Channel map:

Channel 01: FXS Kewlstart (Default) (Slaves: 01)

1 channels configured.

parts of extensions.conf

; We start with what to do when a call first comes in.
exten => s,1,Wait(1) ; Wait a second, just for fun
exten => s,n,Answer ; Answer the line
exten => s,n,Set(TIMEOUT(digit)=5) ; Set Digit Timeout to 5 seconds
exten => s,n,Set(TIMEOUT(response)=10) ; Set Response Timeout to 10 seconds
exten => s,n(restart),BackGround(demo-congrats) ; Play a congratulatory message
exten => s,n(instruct),BackGround(demo-instruct) ; Play some instructions
exten => s,n,WaitExten ; Wait for an extension to be dialed.

; By default we include the demo. In a production system, you
; probably don’t want to have the demo there.
include => demo[/code]

zttool shows alarms OK. I get a light on the correct port of the TDM400P.

I’m sure I’ve overlooked something simple. Any help is greatly appreciated.

Thank you.

check if the phone line works with an handset.

start asterisk using asterisk -cvvvvvvg

Even after this, if you don’t get any messages then asterisk is getting the call.
There may be a problem with the telco line or your settings may be wrong.

Do “zap show channels” at the Asterisk console. If your channel 1 does not show, recompile Asterisk.

Thanks guys.

vinod, I should have mentioned that I had tested the line. It’s fine. Even with the enhanced output I still see nothing.

angler, this seemed to be a good direction. when i initially installed asterisk i had the zaptel software installed but had yet to install my hardware. in any event, i tried what you suggested and there is no “zap show channels” command. In fact, there’s no zap command showing at all. I tried rr-configuring and re-compiling asterkisk but it still didn’t show. So I went back further and did a clean install/compile of the zaptel software, followed by a new install of asterisk. (full configure/make clean/make/make install, that is.) Still, I see no “zap show channels” in at the asterisk command line, and the command fails when i try it.

This must be related to the problem. It seems zaptel is not compiled into asterisk. But how do I get it in there?

What Asterisk version are you using? That command should be working on Asterisk 1.2 from a clean install.

1.4.0-beta 3.

Probably why the command isn’t working. Many commands changed in 1.4, however I do see it in the beta3 code so it should work. Install Asterisk 1.2 and report back.

If the command zap show channels isnt there either zaptel didnt compile for one reason or another.

do lsmod at the linux command and see if the module is loaded.

Best next step is recompile in order. As long as you dont do a make samples you should be OK


OK. I backed down to zaptel version 1.2.11 and asterisk 1.2.13. Both are recompiles. zaptel.conf retained my setting but I needed to reconfigure zapata.conf. I confirmed the asterisk version with “show version” is asterisk CLI.

zaptel appears to be loaded correctly. This is my lsmod output:

[root@localhost modules]# /sbin/lsmod | grep zap zaptel 212004 1 wctdm crc_ccitt 6465 1 zaptel

Sadly, however, I still do not get the “zap show channels” (or any zap command item for that matter) at the CLI.

Well I finally got that working. I suppose I cheated. But I simply installed the RPMs from atrpms. Sure enough, the zap show channels appeared immediately. Something was going wrong with compiling locally, though I can’t say what.

Thanks for your help vinod, angler, and Ian.