Problem configuring Asterisk Realtime with odbc (postgres)

I am having problem while having asterisk work with ODBC (Postgres)
The error that I am getting is
"config.c: Realtime mapping for ‘sippeers’ found to engine ‘odbc’, but the engine is not available"

I really donot know what has went wrong. I have set the ODBC connection properly I have verified it using ::

[root@asterisk ~]# echo "select 1 " | isql asterisk
| Connected! |
| |
| sql-statement |
| help [tablename] |
| quit |
| |
SQL> ±-----------+
| ?column? |
| 1 |
SQLRowCount returns 1
1 rows fetched

Another thing I found is :::
if i do the following

make menuselect

go in option 2. Call Detail Recording
here the option 4. cdr_odbc and option 5. cdr_pgsql both have XXX marked infront of them. And at the bottom of screen it says ODBC CDR Backend Depends on: unixodbc(E)
I donot know why it says so as I have already mentioned below that the odbc connectivity is working fine.
Also I have checked other option in Menuselect everywhere it says same for odbc.

Can someone please let me know what I is wrong here.

Here are the details of the stuff I am using
OS :- fedora core 6 kernel 2798 (Was able to build asterisk on it)
asterisk-addons-1.4.0 (Also tried with or without) :bulb:

If you have XXX in front of the odbc option in the menuselect then it indicates that you don’t have the devel packages installed in your fedora box or that the configure script can’t find them (it already happened to me)

in addition, look in the config.log file to see more detail about why it’s excluded this item from the available list.

I have already installed the development package for unixODBC and Postgresql-Odbc, but still not able to get the menu option without XXX.

I had a similar error. The configure script can’t find the path to the development files. To solve that I downloaded the postgresql tar.gz file then copied it to /usr/local/pgsql and on configure added the --with-postgres=/usr/local/pgsql . That solved the problem.

I now have the cdr_pgsql enable but the cdr_odbc still has the XXX infront of it.

Can you do the same with odbc? I think that the configure script is somewhat broken when trying to find the devel headers as it only looks in one directory tree (ex: /usr/local/pgsql/… )