Polycom IP501 WAN troubles


#1

I’m trying to configure IP501s on a WAN through two firewalls. I’ve given up on NAT for now and just using static IPs. I’m not able to get the phones to register.

I’ve tried numerous sip.conf versions always with the same result:
WARNING[15150]: chan_sip.c:694 retrans_pkt: Maximum retries exceeded on call
This must be because the phones and Asterisk are not yet communicating.
The firewalls are open for communication between the Asterisk server IP and the static phone IPs, port 5060 TCP & UDP , no NAT.

Can someone please post a working sip.conf similar to this scenario, or any other hints would be greatly appreciated.

Thanks.


#2

OK,
I’ve tried every sip.conf nat= option always with the same result.:

FROM CLI> sip reload

Reliably Transmitting:
NOTIFY sip:xx.xx.xx.60 SIP/2.0
Via: SIP/2.0/UDP 10.1.2.12:5060;branch=z9hG4bK4fdc1b12
From: “asterisk” sip:asterisk@10.1.2.12;tag=as11a6db58
To: sip:xx.xx.xx.60
Contact: sip:asterisk@10.1.2.12
Call-ID: 30770b2d15d0ec4c018b88556146511a@10.1.2.12
CSeq: 102 NOTIFY
User-Agent: Asterisk PBX
Event: message-summary
Content-Type: application/simple-message-summary
Content-Length: 42

Messages-Waiting: no
Voice-Message: 0/0
(no NAT) to xx.xx.xx.60:5060
Scheduling destruction of call ‘30770b2d15d0ec4c018b88556146511a@10.1.2.12’ in 15000 ms

I’m beginning to think this just doesn’t work.
My Asterisk server firewall shows the service going out but it’s aparently never sent. The firewall on the client never logs the inbound request.

Has anyone ever gotten this to work???