SIP Phone won't re-register after internet/firewall failure

We currently have 15 remote users whose phones are not in our network (using Cisco SP 303).

For the second time in 3 months we had to reboot our firewall and when this happens 90% of the phones will not reregister with the phone system but a few have no problem.
We have compared the phone config, the extension config and they are identical.

The only thing we found to fix this issue is to have the phone get a different local IP (remember they are on their own home network) and that works most of the time but not always. we sometime simply have to swap the phones to a different extension.

we have tried everything from rebooting the firewall again, the pbx, the phones themselves but we simply can’t figure out why this is happening.

A few additional pieces of information:

  • doing a traffic dump on the firewall shows that our asterisk server keeps trying to connect to the phone on the real ip of the user (not the actual phone’s IP)
  • In some cases changing the phones real ip or even its outside IP has no effect.
  • We have NAT enabled for those extensions

I am willing to provide any config, screen shots traceroutes, tcpdumps needed we just need to figure this out before we start expanding our user base.

this may be something simple we are missing…

thanks for any pointers!

What router/firewall are you using? We have the same issue with the SP 303 and SPA-921 with DrayTek 2820’s.

Hey sorry for the delayed response.

we actually run linux firewalls.

At this point we have reset every device, server, network gear we can think of and out of 8 or so that went dead only 2 are still not able to register…

Since we rebooted the asterisk server I am guessing that the issue isn’t with asterisk so this thread will probably not work out but just in case someone has any thoughts…