Playback only using gsm files

Hi!

I’m using 1.6.0.28 on mipsel/uclib, no g729 codec.
In my sound directory I have gsm, alaw, g729 soundfiles.
If I make sip-call with client that has only g729 enabled, no playback sounds are played back, with following in cli

[Aug 19 16:40:49] NOTICE[532]: rtp.c:1659 ast_rtp_read: Unknown RTP codec 120 received from '192.168.22.98' [Aug 19 16:40:49] WARNING[532]: channel.c:3687 set_format: Unable to find a codec translation path from 0x100 (g729) to 0x2 (gsm) [Aug 19 16:40:49] WARNING[532]: file.c:970 ast_streamfile: Unable to open tt-monkeysintro (format 0x100 (g729)): Resource temporarily unavailable [Aug 19 16:40:49] WARNING[532]: app_playback.c:448 playback_exec: ast_streamfile failed on SIP/23-0000000d for tt-monkeysintro
If I make sip-call with client that has only alaw enabled, the gsm soundfile is played back.
If gsm file is removed (alaw still exists) similar error as above is logged

[Aug 20 13:52:53] WARNING[711] file.c: File tt-weasels does not exist in any format [Aug 20 13:52:53] WARNING[711] file.c: Unable to open tt-weasels (format 0x8 (alaw)): No such file or directory [Aug 20 13:52:53] WARNING[711] app_playback.c: ast_streamfile failed on SIP/20-00000054 for tt-weasels,noanswer
even if I disallow gsm, only gsm files are used by playback …

thanks for any hints/tips
ignaz

Hi!

nobody any clue?
If more info is needed please let me know … I can compile “special” version if needed, but can’t debug.

help much appreciated
ignaz