PAP2 won't register after WAN IP change

I have a Linksys PAP2 behind a D-Link DSL-2540b Modem/Router. The modem and ATA are both new and whenever AT&T changes the WAN IP, the ATA stops registering with my asterisk server. The asterisk server has a static IP and isn’t behind any NAT; so that’s not an issue on that end. If I change the port on the ATA or reboot the modem, suddenly the ATA registers fine and everything works again until the IP changes.

Here’s what I’ve tried so far:
I’ve tried a STUN server,
changing the registration time from 3600 to 600,
numerous settings in the modem/router (dmz the ATA, forwarding ports, differentiated services/QoS, etc.)

I also just changed the SIP T1 to 1 and the Reg Retry Long Intvl to 120 instead of 1200; but I don’t have much hope for these fixes. I’ve searched for people having similar problems and it seems like everyone fixes the problem by buying different devices. Though it’s not always a 2540b and a PAP2 causing the issue. I’m willing to buy a new modem or swap out the ATA if necessary; but I’m hoping someone can tell me what I’m missing to fix this issue. Any advice/help is greatly appreciated and let me know what additional info you need to help diagnose the problem.


Be sure that the option NAT KEEP ALIVE have yes and NAT have yes too.

Sorry, I should have mentioned that both of those were set to Yes.