Paging on loud speaker thru my sound card; boot failure


#1

Hi, after following the instructions to setup loud speaker paging from my sound card, asterisk won’t startup. Here is the guide i followed:
voip-info.org/wiki/view/Sett … sound+card

im using a clean install of asterisk @ home 2.2. i have only created one simple extention for my softphone to use, that used to work fine before i tried addding paging, but now asterisk just won’t startup cuz chan_oss.so failed to load…

it says dsp not found, im assuming thats my sound card device. however, when i goto amp’s sysinfo page it shows that it detected my sound card as this:

00:10.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97]

any ideas whats wrong?

Here are the last few lines in the asterisk log (if you want the whole log, just lemme know):

Jan 13 19:28:06 WARNING[2579] res_musiconhold.c: The old musiconhold.conf syntax has been deprecated! Please refer to the sample configuration for information on the new syntax.
Jan 13 19:28:06 VERBOSE[2579] logger.c: [chan_oss.so]Jan 13 19:28:06 VERBOSE[2579] logger.c: [chan_oss.so] => (OSS Console Channel Driver)
Jan 13 19:28:06 VERBOSE[2579] logger.c: == Parsing ‘/etc/asterisk/oss.conf’: Jan 13 19:28:06 VERBOSE[2579] logger.c: == Parsing ‘/etc/asterisk/oss.conf’: Found
Jan 13 19:28:06 WARNING[2579] config.c: parse error: No category context for line 4 of oss.conf
Jan 13 19:28:06 WARNING[2579] chan_oss.c: could not find <(null)>
Jan 13 19:28:06 NOTICE[2579] chan_oss.c: Device (null) not found
Jan 13 19:28:06 WARNING[2579] loader.c: chan_oss.so: load_module failed, returning -1
Jan 13 19:28:06 WARNING[2579] loader.c: Loading module chan_oss.so failed!
Jan 13 19:28:06 WARNING[2579] loader.c: Loading module chan_oss.so failed


#2

Post your oss.conf file.


#3

;
; Open Sound System Console Driver Configuration File
;
general
;
; Automatically answer incoming calls on the console? Choose yes if
; for example you want to use this as an intercom.
;
autoanswer=yes
;
; Default context (is overridden with @context syntax)
;
context=from-internal
;
; Set overridecontext to yes if you want the context specified above
; to override what someone places on the command line.
;
overridecontext=yes
;
; Default extension to call
;
extension=s
;
; Default language
;
language=en
;
; Silence supression can be enabled when sound is over a certain threshold.
; The value for the threshold should probably be between 500 and 2000 or so,
; but your mileage may vary. Use the echo test to evaluate the best setting.
;silencesuppression = yes
;silencethreshold = 1000
;
; On half-duplex cards, the driver attempts to switch back and forth between
; read and write modes. Unfortunately, this fails sometimes on older hardware.
; To prevent the driver from switching (ie. only play files on your speakers),
; then set the playbackonly option to yes. Default is no. Note this option has
; no effect on full-duplex cards.
playbackonly=yes
;


#4

I too am having the same problem.

I tried initially using onboard sound card, with no sucess, so I installed a PCI card, same problem. I also recompiled inbetween but still to no avail.

Any help would be greatly appreciated.


#5

change general to [general] in oss.conf


#6

zmanea,

Thanks for that, that was a big oversight.

I read somewhere there was a problem with the chan_oss driver, so to rename the old driver that they still include. I then recompiled and I’m getting closer. Now looking in my log file i’m seeing the following:

Jan 16 18:44:24 VERBOSE[2747] logger.c: [chan_oss.so]Jan 16 18:44:24 VERBOSE[2747] logger.c: [chan_oss.so] => (OSS Console Channel Driver)
Jan 16 18:44:24 WARNING[3294] chan_oss.c: Read error on sound device: Resource temporarily unavailable

Can anyone help with this?


#7

zmanea Thank You! works great now!