Outgoing calls randomly go to fast busy

We have a client that has several users that receive a busy tone when calling a number. It is never the same number, or the same user. The user can call the number more than once and get the same result, but another user can call the same number without the fast busy. The user having the issue can call another number with the same area code and it will work fine.

I usually work with commercial systems, so I thought it was an issue with the users Class of Service or dialplan for that user. I have been learning about Asterisk and Trixbox and reviewed the .conf files.

This is what I have checked.

  1. Dialplans.
    The Zap trunk doesn’t have any dialplan assigned. That area is blank. It appears there aren’t Classes of Service in the Trixbox. If other people can dial the number and the same user can call this number on other days it appears to not be a dial plan issue.
  2. Available trunks
    I have been told that when this happens if they delete the user and reassign the user the issue is resolved. I thought maybe they just don’t have enough circuits (they have a 24 channel PRI) and they were getting the fast busy because there were enough circuits at the time. From what I have seen it doesn’t appear to be the issue, but it is impossible to monitor at all times using “Show Channels”. It doesn’t have Munin as an option in tools and the call records don’t suggest this is the issue.
  3. NAT
    All the phones are behind a NAT firebox (Cisco Pix) and the Trixbox is also behind the same firewall. I have noticed that the extensions have NAT=Yes.
  4. Phone
    I am thinking the issue might be the phone itself. They are using Grandstream phones and I am going to have the user switch with a known good phone to see if that helps. It doesn’t appear the phone has a dialplan in it. It might be a DTMF issue.

Is there an easier way to tell what the issue is. On the commercial systems (Audiocodes) I can see the dial stream on the gateway to capture exactly what the phone is dialing to rule out issues. Is there a way to capture this information? Wireshark won’t capture this.

You can actually do a tcpdump on the server’s side and save it to a file to see what is coming in to the server. You can also run ngrep on the server side to see what it receives. I have had lots of issues with grandstream. Have you tried using a soft phone ?

I have users with Xlite that are also having the same issues. I have been trying to review the extensions_additional.conf file to see how the dial plans are setup. I am new to asterisk and to linux. Can you outline a more detailed procedure to troubleshoot this?

They told me the way they always fix this is to delete the account out of Trixbox and recreate it and take out the number in the phone or Xlite and re-register it and it would work, but they didn’t know why. I looked at the results afterwards and saw that when they do that there is not outbound CID. I looked at what was in there before and saw they were inserting a 1 for long distance. For example if their DID was (555)123-1234 they had 1-555-123-1234. I took out the 1 and now they are not having issues. I think the calls were being rejected at the other end because they were able to make some calls it was just a random thing. There is probably one provider like AT&T or something that didn’t like the CID it was receiving so it wouldn’t let it through.

No one else posted, but I wanted to put the solution here because I am tired of people getting their issues resolved and then not letting anyone know how they fixed it.