Originate/Playback without the "beep"

So I wanted to be able to playback an audio file via the asterisk command line. Basically it’s a way for me to announce different things for some of people in calls.

Currently what I’m doing is this:

channel originate Local/8600066 application Playback announceLunch

This works ALMOST perfectly for my purposes.
The problem is that it plays the “beep” sound as if someone is joining, and then the “exit” sound when the sound is done. I would like to originate silently, without the beep sounds, and then play the sound. I have an older method where I created an extension using ChanSpy and then used Playback, but I would really want to avoid having to add an extension for it (I manage many servers so just having a single command would be less work for me).

Any ideas? :thinking:

You haven’t said what extension “8600066” does in the dialplan, which is ultimately what is doing that. If it’s ConfBridge then there are options to disable such sounds.

Ah sorry, well in this case it’s a MeetMe channel.
I’m using Vicidial with Asterisk 13.38.2 (maybe it’s too old?).

MeetMe documentation is on the wiki[1] and includes a ‘q’ option for not playing join/leave sounds. How that fits into your setup is up to you.

[1] Asterisk 13 Application_MeetMe - Asterisk Project - Asterisk Project Wiki

Ah, thank you! Missed that.

Trying to figure out how to change these options for a MeetMe channel that is already running though.

It isn’t already running. Your Originate creates a new channel that joins the MeetMe, plays the sound, and then leaves. The ‘q’ option should be applied to that.

Aha! Sorry for the dumb questions. I’m still fairly new to this. I will read the documentation and see if I can figure this out!