One way audio dialing via disa

I setup an asterisk 1.8 built from source with disa dialing and a sip trunk to my provider. When dialing to the trunk from a sip phone like linksys pap2t located on local network behind nat everything is fine.
However when dialing in via disa from outside and then once disa supplies dialtone dialing via same sip trunk results in one way audio, called party cannot hear me.
The asterisk box is not behind any nat, no firewall. I am puzzled what can be wrong? Tried setting directmedia=no and canreinvite=no in sip.conf, but no success.
Any help would be appreciated.

Have you tried Answer()?

Here’s my setup in extensions.conf:

exten => 777,1,Answer(5)
exten => 777,2,Set(TIMEOUT(digit)=3)
exten => 777,3,Set(TIMEOUT(response)=5)
exten => 777,n,Authenticate(…)
exten => 777,n,Background(vm-enter-num-to-call)
;exten => 777,n,Read(digito,16)
exten => 777,n,DISA(no-password,default)
;exten => 777,n,Goto(default,${digito},1)
exten => 777,n(end),Hangup()

As you can see I tried solution without DISA function as well - same result, called party cannot hear me.
So the problem is in local bridging: incoming call to outgoing call, RTP gets lost somewhere, but why with no NAT or firewall?


Did you try making a packet capture of the call (tcpdump)?