Not receiving events on Asterisk 11 AMI

I’m a veteran of Asterisk 1.4 and am looking to build a new application on Asterisk 11 (which is currently beta, but is planned to be LTS release some time before I need it.)

I can’t get Asterisk Manager Interface on 11 to send me any events. (Now, obviously, in production, I need to cut down these AMI rights drastically, but as I’m exploring I’ve opened the firehose, if you will.)

manager.conf looks like this:

[code] [general]
enabled = yes
port = 5038
bindaddr =

secret = squirrel
deny =
permit =
read = all
write = all[/code]

I then use telnet to try to get in and explore the event stream:

[code] $ telnet localhost 5038
Trying ::1…
telnet: connect to address ::1: Connection refused
Connected to localhost.
Escape character is ‘^]’.
Asterisk Call Manager/1.3
Action: Login
Username: manager
Secret: squirrel
Events: on

Response: Success
Message: Authentication accepted

Event: FullyBooted
Privilege: system,all
Status: Fully Booted[/code]

…and there it sits, not moving, no matter what I actually do with the system. I’ve also tried using the Event manager action with EventMask: on to try to get something out of it; the command is accepted, but nothing changes. It will happily respond to any other actions I send it, though.

Any leads? This sort of thing worked fine under 1.4, and I’m not finding anything in any documentation suggesting I’m doing something wrong. I suppose the next thing to try is 1.8…

(There is little else in /etc/asterisk; I’m using example configs only for reference. This is as minimal as we get…)

Never mind. I am still not sure what was going wrong, but some configuration file cleanup and a restart of Asterisk did it. I’d like to know why that happened, but I doubt I have a way to find out at this point.