Not accpeting incoming calls on SIP - Cisco 7940/60


#1

I’m having some problems with my Asterisk - Cisco 7940/60 configuration and was hoping to find some assistance for a newbie in these forums.

I currently have my astersik server connected to the PSTN using a digium TDM04B (4 FXO ports) adapter which appears to be configured correctly, however all incoming calls to SIP extensions are directed right to voice mail. In addition to the TDM04B adapter, I have also installed a TDM10B (1 FXS port) adapter which has been assigned a extension and can accept incoming calls without issue.

My SIP handsets are mix of Cisco 7940 and 7960, which I have upgraded to P0S3-07-4-00, but don’t seem to be registering properly with Asterisk. I can make outgoing calls (majority of the time, although I do get a fast busy tone about 1 in 10 attempts) but nothing comes in. The phone accepts the config files from the TFTP server and appears to load them properly. That said, even though the setting for each line appearnce are correct the line appearance icon on the main screen appears with a “X”.

I have checked and double checked the config files, but included a sample 7940 config file in case I’m missing something. As you can probably tell from my descripton above I’m a little over my head and am in need of some help. Suggestions Please!

Ryan


#2

Well I seem to have solved my own problem…

I assumed that the problem was with the cisco handsets and after downgrading from firmware v7.4 to v6.3 my phones started to accept incoming calls.

I’m not sure what the exact problem was, but I’m still using the same asterisk installation, conf files, and cisco config files so the firmware version seems to have made all the difference.

I’m debating whether or not to try to upgrade the phone firmware to an earlier version of 7.x.

Has anyone seen this type of issue before? Are there any feature that will not finction under firmware v6.3 that are available in v7.x, or is the new version mainly bug fixes?


#3

Hi there,

I’ve been having the same problem, but with the 4.4 firmware. If the phone is left untouched for a period of time, when I attempt to dial I get the busy signal, if I replace handset and try again it works. Same for incoming calls, if the 7960 hasnt been touched for a while, it goes to voicemail, if its’ been used recently it rings.

I found this which may be of use to you:
voip-info.org/tiki-index.php … cisco+79xx

It mentions a registration problem with 7.5 but says a downgrade to 7.4 solved it, so I’m not sure. That page also gives info on changes between f/w versions.


#4

Quick update, I have tried quite a few firmwares and my 7960 still gets the busy tone if it’s left alone for a while. :frowning:


#5

I had this same problem with the Cisco 7960/7940 phones but resolved it by setting proxy_register to 1 (enable) in SIPDefault.cnf. This fixed the problem instantly after restarting the phones.

# Proxy Registration (0-disable (default), 1-enable) proxy_register: 1
Hope that helps.