Nortel - Asterisk Integration using SIP


#1

Hello,

I’m trying to integrate an Asterisk PBX with a Nortel using SIP.

I can call aout from asterisk to Nortel but the reverse way I can not.

I receive next error message:

Mar 7 07:30:56 DEBUG[2411] chan_sip.c: Setting NAT on RTP to 0
Mar 7 07:30:56 NOTICE[2411] chan_sip.c: Content is ‘multipart/mixed ;boundary=unique-boundary-1’, not 'application/sdp’
Mar 7 07:30:56 VERBOSE[2411] logger.c: Transmitting (no NAT) to 47.46.141.142:5060:
SIP/2.0 488 Not acceptable here

Any Idea?

I found some information in other forum. There someone had same problem and when I contacted him he just told me that He modified chan_sip.c in order to make it comaptible. He did not give the full detail…

Thanks in advance…


#2

are you connecting asterisk with a nortel phone or with a nortel softswitch… ? because I have the project of integrating asterisk with a nortel softswtich here and if you’re doing it too we can mutually colaborate.

Best Regards!


#3

The scenario is as follows:

1.- Nortel CS1000 Rls 4.50W with Signalling Server rls 4.50.25
2.- Asterisk@home rls 1.2.5
3.- Xten softphone attached to Asterisk PBX. I also tested the Unistim solution for Asterisk and it worked fine. I tested i2004 and i2007 sets.
4.- M39XX, i2004, i2007, M2216 st attached to Nortel PBX
5.- SIP trunks between them

Curretn status:

Xten softphone dials to any extension of Nortel PBX - Call completes successfully.

Any Nortel extension dials to Xten softphone - Call can not be completed. When I turn on SIP trace, I see the 488 Not Acceptable Here SIP Message.

As soon as I know, codec negotiation issues can be one of the reasons of such SIP error message. Here I tested using different codec but same result.

The second thing that can be the reason is that Asterisk(chan_sip.c) does not support MIME format. Nortel PBX SIP applications sends for field c the following: Content-Type: multipart/mixed ;boundary=unique-boundary-1

and Asterisk is waiting for something like “application/sdp”.

I found some other posts from someone that modified the chan_sip.c and made it work but He did not want to share the solution

Waiting for your comments…


#4

In asterisk version 1.2.5,

As you guessed, your problem is indeed that asterisk (or chan_sip.c) expects a content-type ‘application/sdp’.

If you are a developper, you may want to change the content of the chan_sip.c code.

You will find your error message line 3416 in the function ‘process_sdp’.

The behaviour is pretty simple : the content type is checked and if it does not match ‘application/sdp’ type, it breaks and returns the error message.

Instead of breaking, you may want to compare to ‘multipart/mixed’ and do the proper behaviour.


#5

I’m not a developer, but I pretend to be.

I modified that part for “application/sdp” in chan_sip.c… What do I need to do in order to apply changes? issue make command?

Regards,