[Noob Question]How to create a User that work in a Softphone


#1

Oke, first: HI @ all =)
I’m from Switzerland, speaking just a bit english :wink:

I’m “forced” to set up a Asterisk Server at my company… Installed all (including samples ^^) and want to configure it…
At the End, the Server had to work in our LAN with Softphone Clients.

So I install X-lite on a other Computer and Start to configure the SIP-Proxy. Adress is the IP, I know, but if I want to login to my server with the following Data, what should I write in the sip.conf on the Server?
Username: Test
Author…-User: Test
Password: Test

???
Probably its very simple, but I’ve got a blackout at the moment, so PLEASE help me!! =)

Thanx
Roger


#2

i am not familier with asterisk what u installed.

me installed asterisk@home and its very easy to configure through gui

when we installed after put ip on server and comeback to GUI make extentions there eg: 200 ,2001 and enter password blah …enter voicemail paswword eg:3234 … then save

open xlite enter username 200 password proxy …ip address of the server

and u can start calling


#3

place this into your iax.conf

[1002]
type=friend
username=1002
secret=12345
context=phone-context
nat=yes
host=dynamic
mailbox=1002
callerid=1002

this is assuming you want to connect via an iax softphone and you have the context setup propery as “phone-context”


#4

Oke, please look at this:
Sip.conf
And then, in X-Lite:

:’(


#5

Sry for doueblepost, edit the first one.


#6

Look herer:

asteriskguru.com/tutorials/a … phone.html

and then:

asteriskguru.com/tutorials/i … phone.html
or
asteriskguru.com/tutorials/x … phone.html
or
asteriskguru.com/tutorials/i … phone.html

or 15 more links for different phones :smile:

Enjoy,


#7

Thanks for the fast answer and the links!

I’ve done it Step by step…

Now, my sip.conf look like this:
langwilig.xeranon.ch/sip.conf.txt
…and my extensions looks now like this:
langwilig.xeranon.ch/extensions.conf.txt

But @ X-Lite, i’ve got the same Failure: “Login Timed out. Connect Network Admin”

What have I done that this all didnt work? :frowning:


#8

does the machine have network connectivity?


#9

I think yes, the 2 machines can ping eachother without any problems…


#10

here is what my sip.conf looks like. for simple sample sip softphone (xlite)

[2001]
type=friend
secret=12345
auth=md5
nat=yes
host=dynamic
reinvite=no
canreinvite=no
qualify=1000
dtmfmode=inband
callerid=“2001” <2001>
diallow=all
allow=gsm
context=yourshere


#11

Only this or all the thing like [general] also?


#12

you need the gernal section too. This is all i have in mine.

[general]
context=your-context ; Default context for incoming calls
realm=your-domain.com ; Realm for digest authentication
; defaults to “asterisk”
; Realms MUST be globally unique according to RFC 3261
; Set this to your host name or domain name
port=5060 ; UDP Port to bind to (SIP standard port is 5060)
bindaddr=0.0.0.0 ; IP address to bind to (0.0.0.0 binds to all)
srvlookup=yes ; Enable DNS SRV lookups on outbound calls
disallow=all ; First disallow all codecs
allow=gsm


#13

tnx, i go to try it in a few minutes

what do you write into your extensions.conf?