No voice on PRI calls with Asterisk 1.4.25 +


we have a problem with voice on PRI’s with the Asterisk versions of 1.4.25 +

On our Asterisk PBX we have two Sangoma cards: a102 & a104.
On the a104 we have 3 PRI’s, on the a102 we have 2 PRI’s.
2 PRI’s from the a104 are connected to a Avaya PBX.

For 2 years everything worked ok with asterisk 1.2… & 1.4….
After upgrade from asterisk to we had no voice on the PRI’s from our asterisk PBX to Avaya (although there was a call, and it was answered), but we did have voice from the Avaya to our Asterisk PBX. The calls were not VOIP calls, they were direct calls on the PRI.
After another upgrade of asterisk to 1.4.26.rc3 the problem was still unsolved, and we had to go back to asterisk

Does anyone have any ideas of how to solve this problem?
We want to upgrade but cant because of it.


  • two Sangoma cards: a102 & a104
    -DHADI: dahdi-linux- dahdi-tools-
    -Kernel: linux-2.6.25-gentoo-r8
  • Snagoma drivers: wanpipe-3.3.16

Thank you!

Solved at