No Sound w/ SPA921 At Remote Site

My setup is as follows:

Asterisk installed at behind a NAT with port 5060 forwarded to it

SPA921 at

I have tried SPA921 with an external IP (connected directly to the internet), as well as behind the firewall (NAT), and have had the same results regardless. The phone can register the account, connect calls, but is unable to send or receive audio. The only case where audio will come through is when I try to check the mailbox - but even then, I can’t actually check the mail, because the keypresses for the password are not being sent to the Asterisk server. I’ve attempted to tell the phone to use STUN, as well as to tell it that it is behind a NAT or otherwise, and this is the best I have been able to do. Does anyone have any ideas or clues that might help me sort this out?

Thanks in advance for any help,

I’ve also been testing out using DD-WRT w/ SER on the client side (, but also haven’t been able to get that to allow sound. I’ve tried using two different ATAs as well, with similar results. I’m really being thrown for a loop here

Do you have all the proper settings in sip.conf for NAT ? Also you need to forward ports 100000 - 20000 on your ruter to the Asterisk server. Also look at the phones configs to make sure that it is using the same ports.

as i always say enabling sip debugging and watching the sip messages also helps.

I found the problem - it turns out it was on the Asterisk server side. What I needed to do was to set the following info in ‘sip_nat.conf’ (which I only figured out by fluke):

nat=yes externip=my_ip localnet= canreinvite=no

On a side note, I highly recommend DD-WRT + SER for any low cost SIP installations. On the client side phones, all I had to do was set the outbound proxy to be the router, and all of the RTP and SIP ports are figured out automatically. Also, the router then keeps its own table of locally connected clients, so that calls to phones on the same router don’t even need to connect to the off site asterisk server.