No sound from Zap channel


#1

I have Fedora Core 4, Asterisk 1.2, TDM400P with 1 fxo and 3 fxs and TDM101P (1 fxo).

# cat /proc/interrupts CPU0 CPU1 0: 19748382 0 IO-APIC-edge timer 1: 20 0 IO-APIC-edge i8042 8: 1 0 IO-APIC-edge rtc 9: 1 0 IO-APIC-level acpi 12: 111 0 IO-APIC-edge i8042 14: 192959 0 IO-APIC-edge ide0 169: 19733569 0 IO-APIC-level wcfxo 201: 15850 0 IO-APIC-level ide2 209: 215996 0 IO-APIC-level SysKonnect SK-98xx 217: 19710970 0 IO-APIC-level wctdm NMI: 0 0 LOC: 19037609 19037524 ERR: 0 MIS: 0
I hope interrupts are ok.

[code]# ztcfg -vv
Zaptel Configuration

Channel map:
Channel 01: FXS Kewlstart (Default) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Slaves: 02)
Channel 03: FXO Kewlstart (Default) (Slaves: 03)
Channel 04: FXO Kewlstart (Default) (Slaves: 04)
Channel 05: FXO Kewlstart (Default) (Slaves: 05)
5 channels configured.[/code]
So channel 1 is my tdm100p.

The problem is when i am calling to pstn from my sip phone i hear no sound only some quiet noise but when i do ztmonitor 2 -v (i call through second channel - Dial(Zap/2/${EXTEN} ) I see that there is an incoming sound like someone talks (I dial the number of the company with IVR menu) and in asterisk CLI I see that everything is ok.
SIP to SIP works fine, and SIP to ZAP/3 (phone connected to fxs of tdm400p) also does

#vi /var/log/asterisk/messages Dec 5 18:51:20 DEBUG[7328] chan_zap.c: Echo cancellation already on Dec 5 18:51:20 VERBOSE[7328] logger.c: -- Zap/2-1 answered SIP/2001-3dcb Dec 5 18:51:20 DEBUG[6477] channel.c: Avoiding initial deadlock for 'SIP/2001-3dcb' Dec 5 18:51:20 DEBUG[6484] chan_sip.c: Stopping retransmission on 'P46oPbSa0V9FK2Dw@192.168.0.238' of Response 2: Match Found

Earlier i used this tdm400p on the same machine (I used asterisk ver. 1.0.9 that time) but with 4 fxo and I had no problems.
Should I try plug off the tdm101p? Did anyone expirience such problems?

Thanks in advance.
P.S. Sorry for my english, it’s not my native language.


#2

Well… the problem’s gone. It seems that I had it because I am stupid and unlucky.
I googled and found that the problem is partially described here lists.digium.com/pipermail/aster … 35160.html
(I had the same problem with incoming calls when * thought It aswered the line and tried to play all its stuff…) but none of those posts helped me.

So I did these steps. Stopped zaptel service, edited /etc/sysconfig/zaptel and made that zaptel service didn’t try to configure wctdm. Started zaptel service. After that I had only wcfxo. Tried to call using it and it worked! Then I edited all those files again and returned back the configuration of wctdm. Now everything works fine.
This is some kind of magic :smiley:.