No RTP engine was found. Do you have one loaded?

I m having this issue on one of my Asterisk Box. It is new installation and all modules are loaded . I Asterisk was installed before on this machine and was working fine.

ubuntu*CLI> core show version
Asterisk SVN-branch-11-r386677 built by root @ ubuntu on a i686

I has been searching and reading on the web but i cant find a real solutions to this problem

I forgot to mention that this installations was performed under a virtual machine environment, how ever i removed the asterisk 11 installation and installed 1.8 and it is working flawless at the time.

As this was packaged by Ubuntu, not Digium, you probably need to get support from Ubuntu. Alternatively just build it yourself form source code.

The obvious first things to do are:

  • run module show to find out which modules are loaded;
  • check the modules directory for rtp handler modules;
  • check the log files for errors during startup;
  • try manually loading the relevant modules and look for errors.

The RTP engines in the trunk version seem to be res_rtp_asterisk and res_rtp_multicast.

Thanks David.

The res_rtp_asterisk module is not installed and it look like some dependency is missing.

This issue happen only with asterisk 11, if i downgrade to asterisk 1.8 work fine.

is there any way to find out what it is missing and why only happen on asterisk 11 installation.

Your menuselect output says that uuid is missing. That’s a libarary for creating unique identifiers. Normally you would expect to find it in /usr/lib/, or /lib/libuuid.*.so, with headers is something like /usr/include/uuid/uuid.h.

If some dependency was missing why if install asterisk 1.8 work fine , this is the output for asterisk 1.8

This installation is running under a virtual machine environment, I don’t know if that might affect

Because Asterisk 1.8 doesn’t use that library. If you look, you can see that the 1.8 screen says Depends on: N/A, but the 11 one says depends on uuid(E).

I am trying to install 11.5 (I know its not released but apparently has some nat force_rport fix)

I get the XXX on res_rtp_asterisk with dependency uuid(e)

I have installed 5 different uuid packages from debian and I still get the XXX

I had 11.4 installed on this system with no problem in that area. Not sure if this is a bug or not and/or its in the right place to post this.

Re run the configure script.

re ran the configure script, make menuselect several times. After getting a new uuid package. cant find any more to try to install to make it work.

I am doing a clean install of 11.5- rc2

Did you install the -dev package?

I have the same problem in version 11.5.0 released today day 15/07/2013.

No RTP engine was found. Do you have one loaded?

i have the same problem. I have 2 numbers and then registered them.
X-lite displays “Your number is …”, it’s okay. And then i make a call between 2 number,
Call Failed: Forbidden
The CLI shows:

[2013-07-16 15:43:28] ERROR[4320][C-00000003]: rtp_engine.c:259 ast_rtp_instance_new: No RTP engine was found. Do you have one loaded? [2013-07-16 15:43:28] NOTICE[4320][C-00000003]: chan_sip.c:25282 handle_request_invite: Failed to authenticate device "theanh3112"<sip:999@>;tag=1135904a

Anyone help me, pls!

Try loading from cli to see what is the error: module load “modulename”.

Hey solved my issue with this one

For 11.5 you need to (debian)
apt-get install uuid-dev
then run ./configure like normal from the beginning. make sure res_rtp_asterisk has an [*] next to it.

Thanks david, It was way down on the package list when i was searching for uuid.

ok in Centos 6.4 - uuid


[quote=“dbbrito”]ok in Centos 6.4 - uuid

I have installed uuid, that was not enought so I’ve installed everything mode packages:

and it helped

I think the extra one needed is libuuid-devel. I didn’t install uuid-c++.

I also didn’t install uuid and uuid-devel on another machine, just lilbuuid-devel and seems to have allowed me to build the rtp module fine.