No inbound calls; sip INVITE not handled by asterisk

N00b here. First time setting up a PBX.

I’m setting up Amazon Chime Voice Connector trunk for use at home. I’ve followed a guide to set it up and I’ve been able to make calls. However, I’m not able to receive calls. All incoming calls get a busy signal. My asterisk server is on a Raspberry PI. I’ve setup my router to forward port 5060 (TCP & UDP) and configured RTP range (10000-20000) to my asterisk server.

I’m able to see the UDP packets when I’m SSH’d into the asterisk server using:
tcpdump -A -s0 -v -i eth0 udp port 5060

However, I’m not seeing anything in asterisk. I’ve enabled logging with
pjsip set logger on

Based on another answer, I’ve made sure to set

Interestingly, the first test call I made, created a buzz of logs, the call was automatically disconnected without any ringing or anything. Every call there after has been unsuccessful getting busy signal and no SIP logging in asterisk.

I’ve disabled iptables using:
service iptables stop

Still nothing…

Any advice here?

This is almost never needed with chan_pjsip, and can be dangerous.

If tcpdump is showing the packets, but Asterisk isn’t, and Asterisk is accepting internally generated calls, I would say you were either wrong about the firewall, or the port number is wrong. However, without logs, we can only guess.

On Sunday 17 March 2024 at 22:32:58, vfeinman via Asterisk Community wrote:

N00b here. First time setting up a PBX.

Any advice here?

Show us your dialplan; show us a packet trace of a call which fails.


It is also possible that putting the birds in a laboratory setting
inadvertently renders them relatively incompetent.

  • Daniel C Dennett

                                                Please reply to the list;
                                                      please *don't* CC me.

Thanks David – I reverted that back to no.

I think you are right about the firewall. I disabled iptables, but I’m on a new version of raspberry pi OS that uses nftables. Following the article how to enable/disable firewall on Raspberry Pi, I executed:
sudo systemctl stop nftables.service
Now Asterisk is logging the inbound call, getting it to work after that was simple.

Now that I know it was the local firewall, I’ll re-enable the firewall and just configure it to allow the necessary traffic.

Thanks for your help David and Pooh!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.