Asterisk doesn't recognize INVITE

#1

Hello guys !!!

I’m facing an scared problem in Asterisk… probably because of some configuration… When I receive an INVITE from other PBX to Asterisk I’m not able to see this INVITE… I tried to collect log " debug_log => notice,warning,error,debug,verbose,dtmf" But there isn’t a single line of log/error ( I restarted logger module), however if I use tcpdump I can see the INVITE hitting the server. The package comes from other PBX in UDP format to the port 5060.

My PJSIP has:

[transport-udp]
type = transport
protocol = udp
bind = 0.0.0.0

[transport-tcp]
type=transport
protocol=tcp
bind=0.0.0.0

[trunk_inbound]
type = identify
endpoint = trunk_inbound
match = 10.10.55.20

[trunk_inbound]
type = endpoint
context = gw_context
dtmf_mode = none
disallow = all
allow = alaw
direct_media = no
aors = trunk_inbound

If I use nestat:

netstat -ntulp | grep 5060
tcp        0      0 0.0.0.0:5060            0.0.0.0:*               LISTEN      2491/asterisk           
udp        0      0 0.0.0.0:5060            0.0.0.0:*                           2491/asterisk

Any ideia what can I do to try to find the problem ?

Thanks

0 Likes

#2

Any received SIP messages would appear with “pjsip set logger on” done on the CLI.

0 Likes

#3

Did you uncomment the log configuration? If so, as Jonathon hints, the INVITE isn’t reaching Asterisk and you need to look elsewhere.

Also, the full log is already configured for maximal logging, once uncommented.

0 Likes

#4

It’s Joshua actually. :smiley:

1 Like

#5

Thank you all ! I solve the problem It was a network problem… But the estrange think was that Asterisk didn’t thrown a single message with “pjsip set logger on” and all logs enabled (uncommented)… The problem was:

Linux was enable to access the IP 10.10.55.20 from where the INVITE comes… but this IP 10.10.55.20 was able to access the Asterisk IP 10.50.10.10… What scared me was that: If I open 2 Linux terminal and in the first one I use:

tcpdump -nqt -s 0 -A -i any port 5060

I was able to see the IP 10.10.55.20 sending an INVITE and the Asterisk server wasn’t answered ( because it was unreachable)

And the Asterisk CLI using:

core set verbose 5
core set debug 5
module reload logger
pjsip set logger on

Didn’t show a SINGLE message !

But anyway was solved IF some one need this is the hint:
If the endpoint it is unreachable by networking problems but you receive request from this endpoint it is not be showed in Asterisk logs.

Again Thank you all !

0 Likes

#6

The lack of any message was the clue.

0 Likes