No audio available - How to Fix

I recently registered a zyxel P2000W wifi but i cannot understand why this phone has no audio at all (in/out). In fact, the * console displays this error:

WARNING[29492]: app.c:644 ast_play_and_record_full: No audio available on SIP/1000-906a??

I appreciate any help fixing this issue. Thanx in advance.

we have a few of these phones, and i didn’t have any issues getting them to work - make sure you have gsm and ulaw enabled for codecs in sip.conf.

i don’t think i had to do anything special otherwise…

yes, i have the same codecs enabled in sip.conf. What firmware version do you have for your phones? I ask this question because I have since found from researching this issue about a multitude of end-users with various problems pointing to different firmware for this particular phone.

Does anyone know “what ast_play_and_record_full” means? Is there someway of emptying it (a file perhaps) so that is is no longer full?

we have the newest version on one, and the default on the other…i don’t have the phones in my office, so i can’t tell you the exact number, but i think there are only two versions anyway.

both worked fine for us.

what version of asterisk/zaptel???

when you find out what versions, please let me know. I use * bus. ed. 1.2.9 on FC4.

business edition is still at 1.0.9…if you’re running 1.2.9, then it’s the standard open-source release.

do a ‘show version’ at the CLI to make sure.

if you ARE running the older version, you might throw a test box together quickly and see how that works.

i just checked the zyxel site, and they are up to firmware WV0004. we have used WV0001 and WV0002 without issue, but i have not tried the newest versions yet.

This is the version the console displayed:
CLI> show version
Asterisk 1.2.9 built by root @ ns15 on a i686 running Linux on 2006-06-18 23:08:25 UTC. And I just downloaded zyxel firmware from yesterday for this phone and it is wj.00.13. Is there anyway, I can get your version? Do you have the Zyxel P2000W or P2000W_v2?

Also, now when i dial my zyxel, i get this readout from the console:
– Executing Dial(“OSS/dsp”, “SIP/1000|15”) in new stack
– Called 1000
– Got SIP response 400 “Bad Request” back from
– SIP/1000-6105 is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)
– Executing Hangup(“OSS/dsp”, “”) in new stack
== Spawn extension (local, 1000, 2) exited non-zero on ‘OSS/dsp’
<< Hangup on console >>
– Got SIP response 400 “Bad Request” back from

Can my ISP have blocked the port? On port 5061, dialing to another phone is fine.

OSS - i haven’t ever seen that particular protocol before…

can you try calling from a SIP or IAX device to the phone? or dial FROM the Zyxel to asterisk, to something like Voicemail or some other basic extension, to test connectivity between the phone and asterisk.

I will try moving this partucular phone to another port later, but it appears this particular port 5060 (sip proxy) has failed here, and it began with silent answered phone calls, as I no longer receive the no audio warning anymore. I do not know why?

Hello all,

Well I found the problem with this issue

" Got SIP response 400 “Bad Request” "

somehow I accidently deleted an equal sign for allow = ulaw in sip.conf. I am still working on the audio situation. But first, I am going to rework my hardware environment. I want my dhcp allocated addresses coming up on the * server rather than my ISP’s static address of particular machines, then that way I can have several port 5060’s being used on one machine. This is possible right? I’m just not quite sure of how to rearrange it right now, so that the router is behind/infront?

OSS is a channel using a sound card via the Console/oss module. most people will have “noload=” before it :smiley:

edit: tlofton, are you the guy with the indescribable network settings, with public addresses on internal interfaces etc etc ??


I have to rearrange, because one of my machines went out on me and therefore, some of my other devices were not working properly - athough I found out later it was not the devices, per say, but a failing machine which ran hard but I worked it anyway. Once I began changing hardware devices around, so far all is well.

Oh, baconbuttie, you’ve got jokes - what timing. What actually do you mean by public addresses on internal interaces? I am sure my setup is different than yours and as I attempted to imply before, I also run dynamic dns and other services so i must work around these services while experimenting with voip, and when you wanted me to draw particular information and provide ip addresses on these wide-scale forum, that was just information I could not post publicly. I will have to research the OSS you mentioned earlier for current/future concerns – and thanx for that note.

i just have this image in my head (from your posts) of a very weird network.

i don’t think it would hurt to have a diagram of your network, any IP addresses that are public could have the last 2 octets 'xxx’d out.

i also don’t understand what “running dynamic dns” is … do you mean subscribe to a dynamic dns service ?

Hopefully the images in your head should last a good while.